BPM
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics

Post Reply
 
Thread Tools Search this Thread
      10-08-2019, 08:36 PM   #23
RickFLM4
Brigadier General
RickFLM4's Avatar
United_States
5389
Rep
4,161
Posts

Drives: M4
Join Date: Jul 2015
Location: PB County, FL

iTrader: (0)

Quote:
Originally Posted by Encanto View Post
https://www.bmwusa.com/owners/software-updates.html

Again... try updating the Media version in the iDrive first, unpair/delete, and pair again. Three BMW (and a VW) in my family and have no issues with all versions of the iPhone 11 (11, Pro and Pro Max).

The latest the Media version is in the iDrive, the more stable the iPhone will be regardless of iOS version.
Which iOS version on those iPhones?
__________________
Current: 2018 SO/SS F83 ZCP
Gone: 2015 SO/SO F82
Appreciate 0
      10-08-2019, 09:16 PM   #24
AlpineWhite_SJ
Banned
United_States
1566
Rep
1,013
Posts

Drives: 2018 F80 M3 ZCP, 2020 F97 X3MC
Join Date: Sep 2017
Location: Bay Area, CA

iTrader: (0)

13.1.2 working fine over Bluetooth for me. Didn’t have to delete and re-pair.
Appreciate 0
      10-09-2019, 02:53 PM   #25
jailonacs99
First Lieutenant
jailonacs99's Avatar
176
Rep
330
Posts

Drives: 2015 M4 (F82)
Join Date: May 2014
Location: Mid-Atlantic

iTrader: (1)

Garage List
2015 BMW M4  [5.00]
Same issue. Re-pair didn't work, and the downloadable BMW software for my VIN is ancient. I'm running 13.1.2 on my iPhone and have a 2015.
Appreciate 0
      10-09-2019, 06:10 PM   #26
RickFLM4
Brigadier General
RickFLM4's Avatar
United_States
5389
Rep
4,161
Posts

Drives: M4
Join Date: Jul 2015
Location: PB County, FL

iTrader: (0)

Quote:
Originally Posted by AlpineWhite_SJ View Post
13.1.2 working fine over Bluetooth for me. Didnít have to delete and re-pair.
You can advance through songs in a playlist using the carís controls with 13.1.2?
__________________
Current: 2018 SO/SS F83 ZCP
Gone: 2015 SO/SO F82
Appreciate 0
      10-09-2019, 06:59 PM   #27
AlpineWhite_SJ
Banned
United_States
1566
Rep
1,013
Posts

Drives: 2018 F80 M3 ZCP, 2020 F97 X3MC
Join Date: Sep 2017
Location: Bay Area, CA

iTrader: (0)

Quote:
Originally Posted by RickFLM4 View Post
You can advance through songs in a playlist using the carís controls with 13.1.2?
Yep.
Appreciate 0
      10-09-2019, 07:03 PM   #28
RickFLM4
Brigadier General
RickFLM4's Avatar
United_States
5389
Rep
4,161
Posts

Drives: M4
Join Date: Jul 2015
Location: PB County, FL

iTrader: (0)

Quote:
Originally Posted by AlpineWhite_SJ View Post
Yep.
Interesting since back in post 15 there is a link to an Apple discussion where numerous people with various auto brands are having issues with 13 through 13.1.2. Guess you got lucky.
__________________
Current: 2018 SO/SS F83 ZCP
Gone: 2015 SO/SO F82
Appreciate 0
      10-09-2019, 08:13 PM   #29
AlpineWhite_SJ
Banned
United_States
1566
Rep
1,013
Posts

Drives: 2018 F80 M3 ZCP, 2020 F97 X3MC
Join Date: Sep 2017
Location: Bay Area, CA

iTrader: (0)

Quote:
Originally Posted by RickFLM4 View Post
Interesting since back in post 15 there is a link to an Apple discussion where numerous people with various auto brands are having issues with 13 through 13.1.2. Guess you got lucky.
Maybe. If I close the music app on the phone it will start playing from the beginning of my library but once I choose an artist, album or playlist and leave the app open it just resumes when I get back in the car. I can advance songs, view album artwork, etc.
Appreciate 0
      10-09-2019, 11:49 PM   #30
jailonacs99
First Lieutenant
jailonacs99's Avatar
176
Rep
330
Posts

Drives: 2015 M4 (F82)
Join Date: May 2014
Location: Mid-Atlantic

iTrader: (1)

Garage List
2015 BMW M4  [5.00]
Quote:
Originally Posted by AlpineWhite_SJ View Post
Quote:
Originally Posted by RickFLM4 View Post
Interesting since back in post 15 there is a link to an Apple discussion where numerous people with various auto brands are having issues with 13 through 13.1.2. Guess you got lucky.
Maybe. If I close the music app on the phone it will start playing from the beginning of my library but once I choose an artist, album or playlist and leave the app open it just resumes when I get back in the car. I can advance songs, view album artwork, etc.
Just to confirm, my car does all that too, but the one thing I can't is selecting songs with the steering wheel control. I can scroll, but if I try to select, nothing happens or if I double click it replays the current song. Only dash controls work.

You don't have those issues? Model year?
Appreciate 0
      10-10-2019, 11:14 AM   #31
AlpineWhite_SJ
Banned
United_States
1566
Rep
1,013
Posts

Drives: 2018 F80 M3 ZCP, 2020 F97 X3MC
Join Date: Sep 2017
Location: Bay Area, CA

iTrader: (0)

Quote:
Originally Posted by jailonacs99 View Post
Just to confirm, my car does all that too, but the one thing I can't is selecting songs with the steering wheel control. I can scroll, but if I try to select, nothing happens or if I double click it replays the current song. Only dash controls work.

You don't have those issues? Model year?
Nope. I tried it on the way in to work this morning and I can change songs via steering wheel and the song list comes up in the HUD.

Model year 2018, iPhone X on latest iOS 13.1.2, iDrive version TB-006.001.044/MB-006.001.044
Appreciate 0
      10-10-2019, 04:55 PM   #32
RickFLM4
Brigadier General
RickFLM4's Avatar
United_States
5389
Rep
4,161
Posts

Drives: M4
Join Date: Jul 2015
Location: PB County, FL

iTrader: (0)

Quote:
Originally Posted by jailonacs99 View Post
Just to confirm, my car does all that too, but the one thing I can't is selecting songs with the steering wheel control. I can scroll, but if I try to select, nothing happens or if I double click it replays the current song. Only dash controls work.

You don't have those issues? Model year?
This is the same for me. I can see playlist in HUD and scroll through it but cannot change songs using either thumb wheel or iDrive controller. I figured out today I can use the arrows next to the #8 key in the dash to play next or previous songs but that’s about it. iPhone 11 with 11.1.2. MB-006.017.006. 2018 F83.

I tried to update iDrive with USB and get “Software on USB device incompatible with this vehicle.” (Even though I entered my VIN and downloaded what BMW provided.). The update downloaded was UPD09042.
__________________
Current: 2018 SO/SS F83 ZCP
Gone: 2015 SO/SO F82
Appreciate 0
      10-11-2019, 08:30 AM   #33
EricVR4
First Lieutenant
EricVR4's Avatar
United_States
352
Rep
389
Posts

Drives: 2018 M3 ZCP MPE
Join Date: Mar 2018
Location: Houston, TX

iTrader: (0)

I'm having the same issue with being able to select/change songs on iDrive/HUD on my 2018 M3. It didn't start until I updated to iOS 13.1.2 the other day. I have an iDrive software update to do though so I guess I'll try that and then un-pair/re-pair the phone and see if it works.
__________________
2018 M3 ZCP MPE - Current | 2017 340i MPPSK BM3 - Sold | 2014 328i - Sold
Appreciate 0
      10-16-2019, 06:36 AM   #34
OrangeD1sco
Private
9
Rep
62
Posts

Drives: None
Join Date: Aug 2014
Location: None

iTrader: (0)

13.1.3 update that went live yesterday fixed it for me. Didn't have to re-pair or do anything other than update my phone.
Appreciate 0
      10-16-2019, 07:31 AM   #35
RickFLM4
Brigadier General
RickFLM4's Avatar
United_States
5389
Rep
4,161
Posts

Drives: M4
Join Date: Jul 2015
Location: PB County, FL

iTrader: (0)

I was just going to ask if anyone tried 13.1.3.

Good to hear these problems have been resolved. Any new problems noticed with the update.

Edit: Updated to 13.1.3 and it didn't fix anything for me. Still can't select and change songs when scrolling through playlist using thumb wheel on steering wheel or iDrive controller. Still not loading all contact in phone. Pretty much exactly the same as it was before the update. Hopefully there are no new problems created in this update.
__________________
Current: 2018 SO/SS F83 ZCP
Gone: 2015 SO/SO F82

Last edited by RickFLM4; 10-16-2019 at 09:44 AM..
Appreciate 0
      10-16-2019, 11:27 AM   #36
Encanto
Major
Encanto's Avatar
710
Rep
1,484
Posts

Drives: 2018 M3
Join Date: Nov 2015
Location: Florida

iTrader: (1)

Quote:
Originally Posted by RickFLM4 View Post
Which iOS version on those iPhones?
Latest version.
Appreciate 0
      10-18-2019, 07:38 AM   #37
OrangeD1sco
Private
9
Rep
62
Posts

Drives: None
Join Date: Aug 2014
Location: None

iTrader: (0)

Quote:
Originally Posted by OrangeD1sco View Post
13.1.3 update that went live yesterday fixed it for me. Didn't have to re-pair or do anything other than update my phone.
Looks like I spoke too soon. Scroll wheel seems to work with some playlists but not others.
Appreciate 0
      10-18-2019, 08:10 AM   #38
EricVR4
First Lieutenant
EricVR4's Avatar
United_States
352
Rep
389
Posts

Drives: 2018 M3 ZCP MPE
Join Date: Mar 2018
Location: Houston, TX

iTrader: (0)

13.1.3 has been working for me now thankfully
__________________
2018 M3 ZCP MPE - Current | 2017 340i MPPSK BM3 - Sold | 2014 328i - Sold
Appreciate 0
      10-18-2019, 09:02 AM   #39
kevBquick
Private First Class
kevBquick's Avatar
40
Rep
156
Posts

Drives: 2015 M3
Join Date: Dec 2013
Location: United States

iTrader: (0)

between 13.1.3 and now it breaks.
beta 13.2.3 finally brings a fix in...but beta 13.2.3 definitely has the fix in it.
__________________
2015 M3 MW 6MT - BM3 | iND
2011 335xi MSport - Alpina shifted FBO on E85 - 388awhp/482awtq
Appreciate 1
domino_z1092.50

      10-18-2019, 10:28 AM   #40
domino_z
Lieutenant Colonel
Australia
1093
Rep
1,952
Posts

Drives: F80 CP
Join Date: Apr 2008
Location: Australia

iTrader: (0)

Same issue here

I can only cycle next/previous using the hard buttons <> on centre stack, and even then it's glitchy and works randomly

Will try deleting and repairing

I just updated to latest 13.1.3 so will give it a go in the morning
Appreciate 0
      10-18-2019, 11:41 AM   #41
pz619
Colonel
2624
Rep
2,908
Posts

Drives: F87 M2C
Join Date: Oct 2013
Location: San Diego

iTrader: (1)

Great news everyone. I just downloaded the public beta for 13.2 and can confirm the playlist features now work. You can sign up for it at this link here. Just need to follow the install directions (super simple).

https://beta.apple.com/sp/betaprogram/

Otherwise, I suspect it'll be out to everyone in November sometime.
Appreciate 1
      10-18-2019, 12:14 PM   #42
millerrh
Enlisted Member
5
Rep
36
Posts

Drives: 2018 BMW M3
Join Date: May 2019
Location: Austin TX

iTrader: (0)

Can't select tracks in iDrive (iPhone)

Currently I am unable to use the iDrive controller (or the steering wheel control) to select tracks on my iPhone. I can scroll through my songs, but pressing down on the controller no longer plays the selected track.

I have tried forgetting the device and repairing as well as restarting my phone and the problem has not gone away.

I'm not sure what caused this to happen. It seems to have been working fine, I disabled the Media connection to my phone so my daughter could watch a cartoon without it playing through the cabin, and upon reactivating the media pairing, this control seems to have been lost.

Anyone ever experience this or know how to fix?
Appreciate 0
      10-18-2019, 12:58 PM   #43
millerrh
Enlisted Member
5
Rep
36
Posts

Drives: 2018 BMW M3
Join Date: May 2019
Location: Austin TX

iTrader: (0)

After some more googling, I found this: Looks to be an issue with iOS 13.1. It's likely I upgraded to 13.1 around the same time I flipped off the media portion for my daughter. But looks like 13.2 fixes it according to this thread.

https://discussions.apple.com/thread/250676400?page=1
Appreciate 0
      10-18-2019, 09:38 PM   #44
pz619
Colonel
2624
Rep
2,908
Posts

Drives: F87 M2C
Join Date: Oct 2013
Location: San Diego

iTrader: (1)

Quote:
Originally Posted by millerrh View Post
Currently I am unable to use the iDrive controller (or the steering wheel control) to select tracks on my iPhone. I can scroll through my songs, but pressing down on the controller no longer plays the selected track.

I have tried forgetting the device and repairing as well as restarting my phone and the problem has not gone away.

I'm not sure what caused this to happen. It seems to have been working fine, I disabled the Media connection to my phone so my daughter could watch a cartoon without it playing through the cabin, and upon reactivating the media pairing, this control seems to have been lost.

Anyone ever experience this or know how to fix?
Fix is one post above you, otherwise you'll need to wait for Apple to release 13.2 gold.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:40 AM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST