Autotalent
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Forum > BMW M3 (F80) and BMW M4 (F82) General Forum

Post Reply
 
Thread Tools Search this Thread
      08-18-2014, 05:20 AM   #1
Racer20
Major
United_States
845
Rep
1,122
Posts

Drives: F80 M3, 228i THP, E46 ZHP
Join Date: May 2009
Location: Ann Arbor, MI

iTrader: (0)

Illuminated M Logo not working

Dumb question, but I noticed that since taking re-delivery of my car last week, the M logo on the front seats isn't lighting up. They worked fine in Germany (albeit with the light buzzing others have mentioned).

Is there a setting to turn these on and off that I'm not seeing?
__________________
2015 M3, 2005 330i ZHP, 2015 228i 6MT Track Handling Pack, 2007 M Coupe (Sold)
Appreciate 0
      08-18-2014, 06:20 AM   #2
Neil McRae
BMW Motorsport
Neil McRae's Avatar
United Kingdom
202
Rep
2,216
Posts

Drives: BMW ///M4 F82 / BMW ///M5 F10
Join Date: Jan 2009
Location: Surrey

iTrader: (1)

Garage List
2020 BMW M5 CP  [0.00]
2015 BMW M4  [5.00]
Send a message via MSN to Neil McRae
is it dark? i noticed they only work in low light (or atleast appears to).
__________________
--
Neil J. //McRae -- Alive and Kicking -- neil at DOMINO.ORG --///M ARMY
M5 CP Alpine White -- M2 LBB -- M4 DCT CP Alpine White
Appreciate 0
      08-18-2014, 06:38 AM   #3
Racer20
Major
United_States
845
Rep
1,122
Posts

Drives: F80 M3, 228i THP, E46 ZHP
Join Date: May 2009
Location: Ann Arbor, MI

iTrader: (0)

Yes, it's dark.
Appreciate 0
      08-18-2014, 02:02 PM   #4
Mako
(Sold) 2000 M Roadster, 2006 M Coupe, 2016 M3
United_States
803
Rep
2,208
Posts

Drives: '20 X3MC DG/SO '19 Volvo XC90
Join Date: Jul 2009
Location: Chicago suburbs

iTrader: (0)

you must have gotten the European version, they only work while the car is in Europe, as soon as it crosses the ocean it stops working
Appreciate 0
      08-18-2014, 04:51 PM   #5
ihateveggies
Private
20
Rep
88
Posts

Drives: M 4
Join Date: Jun 2014
Location: Los Angeles

iTrader: (0)

My passenger side isn't working either. I asked them to check it during my break-in service but they said it was going to take another day to check it out. I said no and took the car after the break-in service cause I really wanted to open the engine up. Will see if they can fix it the next time I'm in. If you take it into service soon, let me know if it's an easy fix!
Appreciate 0
      08-18-2014, 05:30 PM   #6
Drizz
Lieutenant
Drizz's Avatar
161
Rep
588
Posts

Drives: '15 YMB F80; '14 MW F15
Join Date: Dec 2011
Location: Orange County, CA

iTrader: (0)

Huh. Mine light up, but buzz pretty loudly. Hopefully I don't get a jolt to the my back of these days from it.
Appreciate 0
      08-18-2014, 08:46 PM   #7
Racer20
Major
United_States
845
Rep
1,122
Posts

Drives: F80 M3, 228i THP, E46 ZHP
Join Date: May 2009
Location: Ann Arbor, MI

iTrader: (0)

Nevermind. I realized that NONE of my interior/courtesy lights were coming on, so I turn them on with the button on the overhead console and the M logo's lit right up. I'm an idiot.
__________________
2015 M3, 2005 330i ZHP, 2015 228i 6MT Track Handling Pack, 2007 M Coupe (Sold)
Appreciate 0
      08-18-2014, 08:50 PM   #8
SakhirM4
Major General
SakhirM4's Avatar
United_States
10209
Rep
8,706
Posts

Drives: '15 SO M4/'20 Z4 M40i
Join Date: Jul 2014
Location: Austin, TX

iTrader: (0)

Garage List
2020 BMW Z4 M40i  [0.00]
2015 BMW M4  [4.38]
Quote:
Originally Posted by Racer20 View Post
Nevermind. I realized that NONE of my interior/courtesy lights were coming on, so I turn them on with the button on the overhead console and the M logo's lit right up. I'm an idiot.
Sure is refreshing to see someone say "I'm an idiot". We all learn that way
__________________
Tejas Chapter, BMW CCA, mem #23915, President 27 years, www.tejaschapter.org
2015 ///M4, SO/full black, 6MT, HK, light 19"
Appreciate 0
      08-18-2014, 08:56 PM   #9
Wah
IG@i.am.wah
Wah's Avatar
United_States
1681
Rep
3,276
Posts

Drives: 2018 M4 2016 X5
Join Date: Jul 2009
Location: NJ

iTrader: (3)

Quote:
Originally Posted by Racer20 View Post
Nevermind. I realized that NONE of my interior/courtesy lights were coming on, so I turn them on with the button on the overhead console and the M logo's lit right up. I'm an idiot.
Hey this is good info to know! Seriously...
Appreciate 0
      08-18-2014, 09:33 PM   #10
04RC51
Large Member
04RC51's Avatar
943
Rep
1,752
Posts

Drives: E92 M3, F82 M4
Join Date: May 2008
Location: NYC

iTrader: (1)

Quote:
Originally Posted by Racer20 View Post
I'm an idiot.
There are so many people on this forum that need to admit this to themselves.

You just skipped that page in the owner's manual, that's all..
__________________
2008 E92 M3 (Engine swap completed), 2015 F82 M4
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:55 PM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST