EXXEL Distributions
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > DIY and Coding Discussions

Post Reply
 
Thread Tools Search this Thread
      02-14-2016, 02:58 PM   #1
M0011
Major General
M0011's Avatar
1711
Rep
5,106
Posts

Drives: ∞ Improbability Drive
Join Date: Oct 2005
Location: FL

iTrader: (9)

E-Sys won't start

Installed it on Friday, waited 48 hours and all I get is a splash screen. Any inputs? Thanks in advance.
__________________
///f80 YMB/SS 6MT ZCP | f80 | f30 |e92 | tt | S5 | e92 | 350z | e90 |
Appreciate 0
      02-14-2016, 03:55 PM   #2
airboss1971
Enlisted Member
United_States
12
Rep
46
Posts

Drives: 2016 X5M
Join Date: Jan 2015
Location: Victor, ID

iTrader: (0)

I'm assuming you got the program links from Shawn...did you follow the instructions in the PDF? Did you install e-sys launcher premium? What kind of laptop are you using?
Appreciate 0
      02-14-2016, 04:08 PM   #3
M0011
Major General
M0011's Avatar
1711
Rep
5,106
Posts

Drives: ∞ Improbability Drive
Join Date: Oct 2005
Location: FL

iTrader: (9)

Got the stuff from Shawn and installed it. Instructions I got said no token is required and need to wait 48 hours. I did pick the F080 from the dropdown menu.
I'm using Mac running VM and windows XP.
Attached Images
 
__________________
///f80 YMB/SS 6MT ZCP | f80 | f30 |e92 | tt | S5 | e92 | 350z | e90 |
Appreciate 0
      02-14-2016, 04:11 PM   #4
dinonz
Colonel
United_States
1647
Rep
2,362
Posts

Drives: 2016 M3 MWM ZCP
Join Date: Mar 2013
Location: Austin

iTrader: (0)

Quote:
Originally Posted by f80 View Post
Got the stuff from Shawn and installed it. Instructions I got said no token is required and need to wait 48 hours. I did pick the F080 from the dropdown menu.
I'm using Mac running VM and windows XP.
I believe F020 is what you need for an F80 chassis - F80 does not equate to F080.
Appreciate 0
      02-14-2016, 04:19 PM   #5
airboss1971
Enlisted Member
United_States
12
Rep
46
Posts

Drives: 2016 X5M
Join Date: Jan 2015
Location: Victor, ID

iTrader: (0)

For the launcher premium app, you DO want to select F080...it's upon target connection when you're connecting to the car that you will need to select F020 series (and never choose DIRECT mode)
Appreciate 0
      02-14-2016, 04:22 PM   #6
airboss1971
Enlisted Member
United_States
12
Rep
46
Posts

Drives: 2016 X5M
Join Date: Jan 2015
Location: Victor, ID

iTrader: (0)

Quote:
Originally Posted by f80 View Post
Got the stuff from Shawn and installed it. Instructions I got said no token is required and need to wait 48 hours. I did pick the F080 from the dropdown menu.
I'm using Mac running VM and windows XP.
Maybe the memory amount needs to be changed? Not sure how much you have allocated with VM...
Appreciate 0
      02-14-2016, 04:28 PM   #7
dinonz
Colonel
United_States
1647
Rep
2,362
Posts

Drives: 2016 M3 MWM ZCP
Join Date: Mar 2013
Location: Austin

iTrader: (0)

Quote:
Originally Posted by airboss1971 View Post
For the launcher premium app, you DO want to select F080...it's upon target connection when you're connecting to the car that you will need to select F020 series (and never choose DIRECT mode)
Sorry - my mistake!

It's been a few years. Almost 3 to be exact - coded my F30 and have never been back in to change anything.
Appreciate 0
      02-14-2016, 04:43 PM   #8
M0011
Major General
M0011's Avatar
1711
Rep
5,106
Posts

Drives: ∞ Improbability Drive
Join Date: Oct 2005
Location: FL

iTrader: (9)

Quote:
Originally Posted by airboss1971 View Post
Maybe the memory amount needs to be changed? Not sure how much you have allocated with VM...
Allocated over 20 Gig. Still the same.
Attached Images
 
__________________
///f80 YMB/SS 6MT ZCP | f80 | f30 |e92 | tt | S5 | e92 | 350z | e90 |

Last edited by M0011; 02-14-2016 at 05:35 PM..
Appreciate 0
      02-14-2016, 08:29 PM   #9
M0011
Major General
M0011's Avatar
1711
Rep
5,106
Posts

Drives: ∞ Improbability Drive
Join Date: Oct 2005
Location: FL

iTrader: (9)

Still a no go. I re-installed vmware and windows xp, e-sys and the whole deal.
I'll try windows 7 tomorrow.

Mac is an appliance.
PC is a toy.

Unless shawnsheridan chimes in with a solution, I guess I'll just stay stock. No coders in the area.
Attached Images
 
__________________
///f80 YMB/SS 6MT ZCP | f80 | f30 |e92 | tt | S5 | e92 | 350z | e90 |
Appreciate 0
      02-14-2016, 08:35 PM   #10
dinonz
Colonel
United_States
1647
Rep
2,362
Posts

Drives: 2016 M3 MWM ZCP
Join Date: Mar 2013
Location: Austin

iTrader: (0)

Checked your network settings on the VM? There are specific requirements with being in a VM, and also you need to be sure that the assigned ip addresses are in the right range. I have no idea what VMware assigns on a Mac - have not used it in a long long time.
Appreciate 0
      02-14-2016, 08:40 PM   #11
M0011
Major General
M0011's Avatar
1711
Rep
5,106
Posts

Drives: ∞ Improbability Drive
Join Date: Oct 2005
Location: FL

iTrader: (9)

Quote:
Originally Posted by dinonz View Post
Checked your network settings on the VM? There are specific requirements with being in a VM, and also you need to be sure that the assigned ip addresses are in the right range. I have no idea what VMware assigns on a Mac - have not used it in a long long time.
Do network settings have to do anything with the install?
__________________
///f80 YMB/SS 6MT ZCP | f80 | f30 |e92 | tt | S5 | e92 | 350z | e90 |
Appreciate 0
      02-14-2016, 08:44 PM   #12
dinonz
Colonel
United_States
1647
Rep
2,362
Posts

Drives: 2016 M3 MWM ZCP
Join Date: Mar 2013
Location: Austin

iTrader: (0)

Quote:
Originally Posted by f80 View Post
Do network settings have to do anything with the install?
No - the network settings on the VM. Specifically these instructions:

Quote:
*NOTE: The car does NOT have a DHCP server, so it does NOT assign an IP Address to the computer. Both the computer and the car will go into DHCP fallback mode, each assigning themselves a random Class-B IP Address so that they can talk to each other. This can take up to 60 seconds, so you have to wait until the PC has an IP address before you try to connect). Class-B IP Address range is from 128.0.0.0 to 191.255.255.255. Automatic Private IP Addressing (APIPA) is a network client-side process used as a fall-back position when DHCP services are not available on the network but the client devices are configured to use DHCP for their IP address configuration. APIPA allows the client device to randomly choose one of the 65,534 addresses available in the Class B network address of 169.254.0.0/16.

*NOTE: If you are running E-Sys in a Virtual Machine (VM), make sure you set the VM NIC to bridging mode. Do NOT use NAT.
Appreciate 0
      02-15-2016, 09:44 AM   #13
M0011
Major General
M0011's Avatar
1711
Rep
5,106
Posts

Drives: ∞ Improbability Drive
Join Date: Oct 2005
Location: FL

iTrader: (9)

Quote:
Originally Posted by dinonz View Post
*NOTE: If you are running E-Sys in a Virtual Machine (VM), make sure you set the VM NIC to bridging mode. Do NOT use NAT.
Can someone help me set this up?
__________________
///f80 YMB/SS 6MT ZCP | f80 | f30 |e92 | tt | S5 | e92 | 350z | e90 |
Appreciate 0
      02-15-2016, 12:58 PM   #14
dinonz
Colonel
United_States
1647
Rep
2,362
Posts

Drives: 2016 M3 MWM ZCP
Join Date: Mar 2013
Location: Austin

iTrader: (0)

Quote:
Originally Posted by f80 View Post
Can someone help me set this up?
I would if I could - I don't have VMware on my iMac, and I tend to use Windows 99% of the time anyway.

This help?

https://pubs.vmware.com/workstation-...B752D9F42.html
Appreciate 0
      02-15-2016, 02:47 PM   #15
M0011
Major General
M0011's Avatar
1711
Rep
5,106
Posts

Drives: ∞ Improbability Drive
Join Date: Oct 2005
Location: FL

iTrader: (9)

Never mind, found a 12 year old PC laptop in the crawl space. Thanks everyone.
__________________
///f80 YMB/SS 6MT ZCP | f80 | f30 |e92 | tt | S5 | e92 | 350z | e90 |
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:10 AM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST