EXXEL Distributions
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics

Post Reply
 
Thread Tools Search this Thread
      11-01-2018, 12:43 PM   #1
Gronkspike
New Member
3
Rep
20
Posts

Drives: 2018 BMW M3 CZP
Join Date: Oct 2015
Location: Rhode Island

iTrader: (0)

Radio Presets default setting?

Sorry if this is reposting. I had trouble finding a solution to the issue I'm having with the radio. I only use my presets, never FM or AM or even satellite. On my previous M3, when starting the vehicle, the radio would always have my presets selected. Now with this new M3, the radio has FM selected instead of my presets. Is there a way to have my presets set to default on start up? Thanks in advance.
Appreciate 0
      11-02-2018, 12:51 PM   #2
backagain
just a fool
backagain's Avatar
China
329
Rep
673
Posts

Drives: 2016 SO coded M3
Join Date: Mar 2016
Location: CA bay area

iTrader: (0)

Quote:
Originally Posted by Gronkspike View Post
Sorry if this is reposting. I had trouble finding a solution to the issue I'm having with the radio. I only use my presets, never FM or AM or even satellite. On my previous M3, when starting the vehicle, the radio would always have my presets selected. Now with this new M3, the radio has FM selected instead of my presets. Is there a way to have my presets set to default on start up? Thanks in advance.
It should start with the audio source (and channel) that you last used.
Appreciate 0
      11-03-2018, 07:11 AM   #3
Spiff7
Second Lieutenant
Spiff7's Avatar
68
Rep
225
Posts

Drives: 2018 BMW F80 M3 ZCP
Join Date: Nov 2010
Location: NY

iTrader: (1)

My car does something similar since day one. Unlike my previous BMWs where on startup it would be where I last left off, usually my presets, this one usually shows the screen where you select presets, satellite radio, xm, am, etc. It also usually highlights the satellite radio selection. It's a little annoying to have to change it back to my presets each time. I mentioned it to SA at 1200 service thinking it needed a reboot or update but they did nothing to address it. It was kind of one of those "oh that's just the way the 2018s Ms are." I've also noticed the temp on either of the driver or passenger dials will be one degree off from where I last had it from time to time. It's very bizarre.
__________________
2017 F30 340i x-drive PPSK
2014 F30 335i x-drive M-Package (retired)
2011 E92 335i x-drive M-Package (retired)
2008 E92 328xi (retired)
2001 E46 325xi (retired)
Appreciate 0
      11-05-2018, 12:15 PM   #4
Gronkspike
New Member
3
Rep
20
Posts

Drives: 2018 BMW M3 CZP
Join Date: Oct 2015
Location: Rhode Island

iTrader: (0)

Quote:
Originally Posted by Spiff7 View Post
My car does something similar since day one. Unlike my previous BMWs where on startup it would be where I last left off, usually my presets, this one usually shows the screen where you select presets, satellite radio, xm, am, etc. It also usually highlights the satellite radio selection. It's a little annoying to have to change it back to my presets each time. I mentioned it to SA at 1200 service thinking it needed a reboot or update but they did nothing to address it. It was kind of one of those "oh that's just the way the 2018s Ms are." I've also noticed the temp on either of the driver or passenger dials will be one degree off from where I last had it from time to time. It's very bizarre.
Yes this is exactly what I'm referring to. Very annoying and it usually defaults to satellite radio on mine as well. I'll continue to see if there is a solution to this.
Appreciate 0
      11-05-2018, 12:17 PM   #5
Spiff7
Second Lieutenant
Spiff7's Avatar
68
Rep
225
Posts

Drives: 2018 BMW F80 M3 ZCP
Join Date: Nov 2010
Location: NY

iTrader: (1)

Quote:
Originally Posted by Gronkspike View Post
Yes this is exactly what I'm referring to. Very annoying and it usually defaults to satellite radio on mine as well. I'll continue to see if there is a solution to this.
Yes, please keep me posted and I will let you know if I find anything out as well. It is very annoying!
__________________
2017 F30 340i x-drive PPSK
2014 F30 335i x-drive M-Package (retired)
2011 E92 335i x-drive M-Package (retired)
2008 E92 328xi (retired)
2001 E46 325xi (retired)
Appreciate 0
      11-27-2018, 11:35 PM   #6
Spiff7
Second Lieutenant
Spiff7's Avatar
68
Rep
225
Posts

Drives: 2018 BMW F80 M3 ZCP
Join Date: Nov 2010
Location: NY

iTrader: (1)

Quote:
Originally Posted by Gronkspike View Post
Quote:
Originally Posted by Spiff7 View Post
My car does something similar since day one. Unlike my previous BMWs where on startup it would be where I last left off, usually my presets, this one usually shows the screen where you select presets, satellite radio, xm, am, etc. It also usually highlights the satellite radio selection. It's a little annoying to have to change it back to my presets each time. I mentioned it to SA at 1200 service thinking it needed a reboot or update but they did nothing to address it. It was kind of one of those "oh that's just the way the 2018s Ms are." I've also noticed the temp on either of the driver or passenger dials will be one degree off from where I last had it from time to time. It's very bizarre.
Yes this is exactly what I'm referring to. Very annoying and it usually defaults to satellite radio on mine as well. I'll continue to see if there is a solution to this.
Quote:
Originally Posted by Gronkspike View Post
Quote:
Originally Posted by Spiff7 View Post
My car does something similar since day one. Unlike my previous BMWs where on startup it would be where I last left off, usually my presets, this one usually shows the screen where you select presets, satellite radio, xm, am, etc. It also usually highlights the satellite radio selection. It's a little annoying to have to change it back to my presets each time. I mentioned it to SA at 1200 service thinking it needed a reboot or update but they did nothing to address it. It was kind of one of those "oh that's just the way the 2018s Ms are." I've also noticed the temp on either of the driver or passenger dials will be one degree off from where I last had it from time to time. It's very bizarre.
Yes this is exactly what I'm referring to. Very annoying and it usually defaults to satellite radio on mine as well. I'll continue to see if there is a solution to this.
Curious, what's the build date of your car?
__________________
2017 F30 340i x-drive PPSK
2014 F30 335i x-drive M-Package (retired)
2011 E92 335i x-drive M-Package (retired)
2008 E92 328xi (retired)
2001 E46 325xi (retired)
Appreciate 0
      11-28-2018, 12:10 AM   #7
F806speed
New Member
No_Country
50
Rep
19
Posts

Drives: ///M3
Join Date: Aug 2018
Location: nY

iTrader: (0)

You could set one of your hot keys to radio presets
Appreciate 0
      05-27-2019, 10:22 AM   #8
nickl630
Lieutenant
nickl630's Avatar
United_States
177
Rep
431
Posts

Drives: 18 M3CS, 09 GTR
Join Date: Jan 2015
Location: Tampa, FL

iTrader: (1)

Send a message via AIM to nickl630
bumping this thread... came from a 17 F80 to an 18 CS and it's doing the same thing with the presets... very annoying. I'll bring it up with I get my break-in service done.
Appreciate 0
      06-12-2019, 04:16 PM   #9
TN_3
Major
TN_3's Avatar
United_States
292
Rep
1,339
Posts

Drives: 2018 M3 CS
Join Date: Oct 2007
Location: Franklin, TN

iTrader: (10)

Garage List
Quote:
Originally Posted by nickl630 View Post
bumping this thread... came from a 17 F80 to an 18 CS and it's doing the same thing with the presets... very annoying. I'll bring it up with I get my break-in service done.
Another issue with the same thing...came from '16 F80 to CS and sometimes it will stay on presets when I start back up, other times will go to source last listened to (XM, even if the station was in the presets). Notified the local BMW genius who is touch with corporate and is digging for details.
__________________
2018 M3 CS F80 l SMB l EXEC

2020 X5 M50i G05 l MW l BLACK l PREM l DHP l 22 l PARK l EXT S-LINE l LASER l TH l AG
Appreciate 0
      06-17-2019, 08:51 PM   #10
nickl630
Lieutenant
nickl630's Avatar
United_States
177
Rep
431
Posts

Drives: 18 M3CS, 09 GTR
Join Date: Jan 2015
Location: Tampa, FL

iTrader: (1)

Send a message via AIM to nickl630
Quote:
Originally Posted by TN_3 View Post
Another issue with the same thing...came from '16 F80 to CS and sometimes it will stay on presets when I start back up, other times will go to source last listened to (XM, even if the station was in the presets). Notified the local BMW genius who is touch with corporate and is digging for details.
Let me know if you hear anything. No luck after break in service here. Completely random when it does it too.
Appreciate 0
      06-19-2019, 05:18 PM   #11
TN_3
Major
TN_3's Avatar
United_States
292
Rep
1,339
Posts

Drives: 2018 M3 CS
Join Date: Oct 2007
Location: Franklin, TN

iTrader: (10)

Garage List
Quote:
Originally Posted by nickl630 View Post
Let me know if you hear anything. No luck after break in service here. Completely random when it does it too.
Genius got back to me, said engineers aren't sure why it is doing it and can't pin down what causes it to default one way or the other. They are "working on it".
__________________
2018 M3 CS F80 l SMB l EXEC

2020 X5 M50i G05 l MW l BLACK l PREM l DHP l 22 l PARK l EXT S-LINE l LASER l TH l AG
Appreciate 0
      06-19-2019, 07:30 PM   #12
Cars are the new horse
First Lieutenant
United_States
78
Rep
380
Posts

Drives: 2019 M4
Join Date: May 2009
Location: USA

iTrader: (0)

I have this same issue.
Appreciate 0
      07-19-2019, 03:51 PM   #13
Cars are the new horse
First Lieutenant
United_States
78
Rep
380
Posts

Drives: 2019 M4
Join Date: May 2009
Location: USA

iTrader: (0)

Is there an update that resolves this and do 2020s have this problem? I ask because my car is at the dealership right now and if there is an update that resolves this issue, then I'd like to apply it.
Appreciate 0
      07-22-2019, 12:40 PM   #14
TN_3
Major
TN_3's Avatar
United_States
292
Rep
1,339
Posts

Drives: 2018 M3 CS
Join Date: Oct 2007
Location: Franklin, TN

iTrader: (10)

Garage List
Quote:
Originally Posted by nirvanayoda View Post
Is there an update that resolves this and do 2020s have this problem? I ask because my car is at the dealership right now and if there is an update that resolves this issue, then I'd like to apply it.
No update that I am aware of...my genius said he spoke with BMW engineers who admitted this behavior but did not indicate they were going to be working on an immediate fix. Maybe we see something snuck into a future update without much fanfare.
__________________
2018 M3 CS F80 l SMB l EXEC

2020 X5 M50i G05 l MW l BLACK l PREM l DHP l 22 l PARK l EXT S-LINE l LASER l TH l AG
Appreciate 0
      08-14-2019, 05:44 PM   #15
Gronkspike
New Member
3
Rep
20
Posts

Drives: 2018 BMW M3 CZP
Join Date: Oct 2015
Location: Rhode Island

iTrader: (0)

Quote:
Originally Posted by Spiff7 View Post
Curious, what's the build date of your car?
Sorry took soo long to get back. I was just doing a search on this very topic and linked back to this thread. Mine was one of the last 2018's available to buy at my dealer. Purchased August 2018, unsure about build date.

Still have this issue...still very annoying
Appreciate 0
      08-14-2019, 10:38 PM   #16
Spiff7
Second Lieutenant
Spiff7's Avatar
68
Rep
225
Posts

Drives: 2018 BMW F80 M3 ZCP
Join Date: Nov 2010
Location: NY

iTrader: (1)

I ended up having the car flashed at dealer months ago (4th quarter of 2018) to see if it would correct the issue but it did not.

I recently bought it back in a month ago to get it checked out again and BMW acknowledged an issue with it. They are supposed working on a patch to correct the issue. Dealer said once they are notified from BMW that a patch has been created to correct the issue they will contact me and apply it to my vehicle. I'm thinking about following up with dealer this week.

FYI my car is a June 2018 build date.
__________________
2017 F30 340i x-drive PPSK
2014 F30 335i x-drive M-Package (retired)
2011 E92 335i x-drive M-Package (retired)
2008 E92 328xi (retired)
2001 E46 325xi (retired)
Appreciate 0
      09-19-2019, 07:57 AM   #17
jinfield
Registered
0
Rep
1
Posts

Drives: 2014 328i, 2020 440i XDrive
Join Date: Sep 2019
Location: Memphis, TN

iTrader: (0)

Radio Presets default setting

I had a 2014 328i and it maintained my preset selection. I upgraded to a 2020 440i XDrive in Mid July and have had this issue from the beginning. Once it even lost all the presets I had saved. Even more annoying.
Appreciate 0
      10-25-2019, 02:18 PM   #18
luvsql1
New Member
0
Rep
6
Posts

Drives: 2020 BMW 230i
Join Date: Sep 2019
Location: Toronto, ON Canada

iTrader: (0)

I have a 2020 230i and mine does the same thing. Super annoying as I only use my presets so when i scroll to another favourite, it's the full channel list then have to switch it back to presets etc.
Appreciate 0
      12-11-2019, 02:38 AM   #19
Crazy Penguin
Second Lieutenant
81
Rep
249
Posts

Drives: Jet Black
Join Date: Sep 2011
Location: Suffolk

iTrader: (1)

Delete your driver profiles. The profile file is corrupt.
Appreciate 0
      12-11-2019, 11:21 PM   #20
Cars are the new horse
First Lieutenant
United_States
78
Rep
380
Posts

Drives: 2019 M4
Join Date: May 2009
Location: USA

iTrader: (0)

There is a bulletin on this. My dealership found it and supposedly corrected the issue today. We’ll see over the course of the next week.
Appreciate 0
      12-12-2019, 10:27 PM   #21
Cars are the new horse
First Lieutenant
United_States
78
Rep
380
Posts

Drives: 2019 M4
Join Date: May 2009
Location: USA

iTrader: (0)

This is indeed fixed now.
Appreciate 0
      12-13-2019, 01:36 AM   #22
danchee
First Lieutenant
68
Rep
318
Posts

Drives: 18' F80 M3 Laguna Seca Blue
Join Date: Dec 2009
Location: Rainy City

iTrader: (0)

And what was the fix?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:33 AM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST