HRE Wheels
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Engine / Drivetrain / Exhaust / Bolt-ons / Tuning

Post Reply
 
Thread Tools Search this Thread
      06-22-2019, 10:04 PM   #1
NVMYM2
New Member
3
Rep
13
Posts

Drives: BMW M2
Join Date: Mar 2018
Location: Brookfield,CT

iTrader: (0)

BIMMERPOST
     Featured on BIMMERPOST.com
I'm full bolt on F80 M3 with a custom e30 tune from BM3. My clutch started slipping so I decided to upgrade to the clutchmasters FX350. My BMW tech friend installed it and it just doesn't feel right. I would assume that it would feel heavier or harder but the pedal feel is super light. Slightly lighter than OEM. He installed all parts correctly except the throw out bearing supplied wasn't staying on the fork so we kept the OEM one on. He also mentioned having a tough time with the spring for the clutch. Either way the clutch itself feels fine but the pedal feel is way off. It's not that heavy. Any thoughts on what could be wrong?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:00 AM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST