VIBE Motorsports
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics

Post Reply
 
Thread Tools Search this Thread
      10-21-2020, 11:39 PM   #1
sagi
Private First Class
23
Rep
127
Posts

Drives: F80
Join Date: Sep 2018
Location: Toronto

iTrader: (0)

Lci trim retrofit

Hello

Has anyone tried this mod? I bought the parts within the link and it all fits except for the bottom panel that sits above the cup holders. (Panel that hides the bottom screws of the Ac control trim). The panel is loose and if I tap on the sides a few times it will drop.

It almost seems like it doesn’t clip in securely into the bottom of the trim compared to the original. I have a 2015 m3.

Any ideas on how I can get it to stay?

Does anyone have the trim part number for a 2017+ bmw m3?

https://f80.bimmerpost.com/forums/sh....php?t=1672204
Appreciate 0
      10-22-2020, 10:16 PM   #2
Encanto
Lieutenant Colonel
Encanto's Avatar
United_States
736
Rep
1,526
Posts

Drives: 2021 X3 M40i
Join Date: Nov 2015
Location: Ohio

iTrader: (1)

Search in the F30 forum.

Quote:
Originally Posted by sagi View Post
Hello

Has anyone tried this mod? I bought the parts within the link and it all fits except for the bottom panel that sits above the cup holders. (Panel that hides the bottom screws of the Ac control trim). The panel is loose and if I tap on the sides a few times it will drop.

It almost seems like it doesn’t clip in securely into the bottom of the trim compared to the original. I have a 2015 m3.

Any ideas on how I can get it to stay?

Does anyone have the trim part number for a 2017+ bmw m3?

https://f80.bimmerpost.com/forums/sh....php?t=1672204
Appreciate 0
      11-02-2020, 03:59 PM   #3
psyki
E36fiend
United_States
234
Rep
541
Posts

Drives: 2014 435i xDrive
Join Date: May 2019
Location: Sammamish, WA

iTrader: (1)

Garage List
2014 435i xDrive  [0.00]
2014 X5  [0.00]
You kinda just have to work it a bit. Take it out and put it back in a few times, it has to be in a certain position for it to clip into place. Also the trim piece you installed has enlarged mounting holes that allow for a little play in the placement, you might try adjusting the position a bit, retighten the screws and see if the cover will stay clipped into place.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:39 PM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST