BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics

Post Reply
 
Thread Tools Search this Thread
      10-27-2020, 06:54 PM   #1
Prudvi_12
Enlisted Member
3
Rep
34
Posts

Drives: 2016 BMW f80 M3
Join Date: Jan 2020
Location: New Jersey

iTrader: (0)

Bluetooth Connection Keeps Cutting Out

Anyone else having an issue with there Bluetooth or usb connection keep cutting out. I have a 2016 bmw m3. Every time I connect my phone with Bluetooth the song plays and cuts out after 1-3 minutes and the same happens for the usb connection. This issue happened back in may but I have been driving the car much so it wasn't a big deal but now it's becoming ridiculous. BMW said everything with the car is fine and Apple said everything with my phone is fine. Anyone else have this issue and know how to fix it?
Appreciate 0
      11-10-2020, 09:30 PM   #2
Darkmann
Enlisted Member
17
Rep
47
Posts

Drives: F80 M3
Join Date: Apr 2020
Location: US - Maryland

iTrader: (0)

I have a similar problem and am looking a solutions. I have an iPhone 7P and Apple Car Play on both my M3 and X5 M-Sport. I also have SiriusXM on both vehicles. On both vehicles, every so often, the phone will open up CarPlay and when it does that it disconnects me completely from SiriusXM. On a 1-hr drive, it can do this up to 10 times - so annoying that I'm not using radio much anymore. I am wondering if it's the iOS version - I'm at 14.2 now, but it did it in 14.1 also. I am planning to call BMW to see if they have a solution.
Appreciate 0
      11-14-2020, 06:47 PM   #3
rmizzle101
First Lieutenant
United_States
144
Rep
355
Posts

Drives: 2016 YMB M4
Join Date: Aug 2015
Location: Fresno

iTrader: (0)

This happens to me as well. 2016 m4... happened on every iPhone I've had, even with the newest one. Convinced this is a BMW issue — I've also sent to dealership and they claim nothing is wrong.

It's very frustrating & annoying. Would love to know if anybody finds a solution.
Appreciate 0
      11-15-2020, 11:43 AM   #4
Prudvi_12
Enlisted Member
3
Rep
34
Posts

Drives: 2016 BMW f80 M3
Join Date: Jan 2020
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by rmizzle101 View Post
This happens to me as well. 2016 m4... happened on every iPhone I've had, even with the newest one. Convinced this is a BMW issue — I've also sent to dealership and they claim nothing is wrong.

It's very frustrating & annoying. Would love to know if anybody finds a solution.
Yeah I think it's definitely an issue with Bmw because I went to apple and they gave me a replacement phone and the issue keeps on happening, the only option I'm left at this point is just to upgrade my idrive or to get the car play module.
Appreciate 0
      11-18-2020, 11:40 PM   #5
ONEof500
Private First Class
United_States
46
Rep
143
Posts

Drives: 2017 M3 30 Jahre
Join Date: Feb 2016
Location: California

iTrader: (0)

Mine cuts out during music and plays through the cars hands free speaker for a few seconds and then goes back to the regular speakers. Only happens when I start driving and then does not come back until next time I drive.
Appreciate 0
      11-22-2020, 09:46 PM   #6
rmizzle101
First Lieutenant
United_States
144
Rep
355
Posts

Drives: 2016 YMB M4
Join Date: Aug 2015
Location: Fresno

iTrader: (0)

Quote:
Originally Posted by Prudvi_12 View Post
Quote:
Originally Posted by rmizzle101 View Post
This happens to me as well. 2016 m4... happened on every iPhone I've had, even with the newest one. Convinced this is a BMW issue — I've also sent to dealership and they claim nothing is wrong.

It's very frustrating & annoying. Would love to know if anybody finds a solution.
Yeah I think it's definitely an issue with Bmw because I went to apple and they gave me a replacement phone and the issue keeps on happening, the only option I'm left at this point is just to upgrade my idrive or to get the car play module.
How do you update the idrive?
Appreciate 0
      11-25-2020, 08:33 AM   #7
duky
The Tanzanian
duky's Avatar
United_States
984
Rep
1,305
Posts

Drives: BSM F80
Join Date: Jan 2012
Location: Oakland, CA

iTrader: (8)

Garage List
2016 BMW M3  [5.00]
Have this issue but I'm pretty sure it's an Apple change as it started around the time I moved to iOS 14. Didn't happen before. I thought getting a new phone would solve it but it still happens on my iPhone 12 (set up as new). Very unpredictable when it cuts out and whether/how to get it back
__________________
Current: 2016 F80 Black Sapphire Metallic on Silverstone
Former: 2007 E90 335i Barbera Red on Terra Dakota
Appreciate 0
      11-28-2020, 11:48 AM   #8
Prudvi_12
Enlisted Member
3
Rep
34
Posts

Drives: 2016 BMW f80 M3
Join Date: Jan 2020
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by rmizzle101 View Post
Quote:
Originally Posted by Prudvi_12 View Post
Quote:
Originally Posted by rmizzle101 View Post
This happens to me as well. 2016 m4... happened on every iPhone I've had, even with the newest one. Convinced this is a BMW issue — I've also sent to dealership and they claim nothing is wrong.

It's very frustrating & annoying. Would love to know if anybody finds a solution.
Yeah I think it's definitely an issue with Bmw because I went to apple and they gave me a replacement phone and the issue keeps on happening, the only option I'm left at this point is just to upgrade my idrive or to get the car play module.
How do you update the idrive?
There are a few company's that do it. Retrofitmybeamer on Instagram does it, you have to replace your head unit and it's pretty expensive($1200). Still debating on if I should get that or just a apple play car module.
Appreciate 0
      11-28-2020, 11:49 AM   #9
Prudvi_12
Enlisted Member
3
Rep
34
Posts

Drives: 2016 BMW f80 M3
Join Date: Jan 2020
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by duky View Post
Have this issue but I'm pretty sure it's an Apple change as it started around the time I moved to iOS 14. Didn't happen before. I thought getting a new phone would solve it but it still happens on my iPhone 12 (set up as new). Very unpredictable when it cuts out and whether/how to get it back
This is annoying, I wish bmw just updated their idrive so it was perfectly compatible with iOS 14. Also do you use Apple Music and it happens to you or another streaming service?
Appreciate 0
      11-29-2020, 08:34 AM   #10
duky
The Tanzanian
duky's Avatar
United_States
984
Rep
1,305
Posts

Drives: BSM F80
Join Date: Jan 2012
Location: Oakland, CA

iTrader: (8)

Garage List
2016 BMW M3  [5.00]
Quote:
Originally Posted by Prudvi_12 View Post
Quote:
Originally Posted by duky View Post
Have this issue but I'm pretty sure it's an Apple change as it started around the time I moved to iOS 14. Didn't happen before. I thought getting a new phone would solve it but it still happens on my iPhone 12 (set up as new). Very unpredictable when it cuts out and whether/how to get it back
This is annoying, I wish bmw just updated their idrive so it was perfectly compatible with iOS 14. Also do you use Apple Music and it happens to you or another streaming service?
I don't use streaming it is all on the device played through apples music app. Disabling Bluetooth then re-enabling it on the phone seems to be the way to get it back when it stops
__________________
Current: 2016 F80 Black Sapphire Metallic on Silverstone
Former: 2007 E90 335i Barbera Red on Terra Dakota
Appreciate 0
      11-29-2020, 10:18 AM   #11
Encanto
Lieutenant Colonel
Encanto's Avatar
United_States
736
Rep
1,525
Posts

Drives: 2021 X3 M40i
Join Date: Nov 2015
Location: Ohio

iTrader: (1)

Quote:
Originally Posted by Prudvi_12 View Post
This is annoying, I wish bmw just updated their idrive so it was perfectly compatible with iOS 14. Also do you use Apple Music and it happens to you or another streaming service?
Have you deleted the phone from the car, the car from the phone, and re-paired?
Appreciate 0
      11-30-2020, 09:41 PM   #12
Prudvi_12
Enlisted Member
3
Rep
34
Posts

Drives: 2016 BMW f80 M3
Join Date: Jan 2020
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Encanto View Post
Quote:
Originally Posted by Prudvi_12 View Post
This is annoying, I wish bmw just updated their idrive so it was perfectly compatible with iOS 14. Also do you use Apple Music and it happens to you or another streaming service?
Have you deleted the phone from the car, the car from the phone, and re-paired?
Yeah a few times, after I got the new phone from apple and repaired that the problem happens a little less frequently, like maybe every 2-3 songs
Appreciate 0
      12-01-2020, 12:11 AM   #13
M's ///M
New Member
7
Rep
8
Posts

Drives: F80 M3
Join Date: Oct 2020
Location: NoVa

iTrader: (1)

Do you have any other devices connected via Bluetooth, or simply paired to your phone when you run into this issue?

If you do, try completely removing all other paired devices (forget this device) and test with just the iDrive. If it works, begin pairing your other devices one by one and retesting after each device.

In my case, it would only begin failing after I paired this one particular device and thankfully it was a device I no longer used much so problem solved in my case.

Mo
Appreciate 0
      12-01-2020, 02:54 AM   #14
Prudvi_12
Enlisted Member
3
Rep
34
Posts

Drives: 2016 BMW f80 M3
Join Date: Jan 2020
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by duky View Post
Quote:
Originally Posted by Prudvi_12 View Post
Quote:
Originally Posted by duky View Post
Have this issue but I'm pretty sure it's an Apple change as it started around the time I moved to iOS 14. Didn't happen before. I thought getting a new phone would solve it but it still happens on my iPhone 12 (set up as new). Very unpredictable when it cuts out and whether/how to get it back
This is annoying, I wish bmw just updated their idrive so it was perfectly compatible with iOS 14. Also do you use Apple Music and it happens to you or another streaming service?
I don't use streaming it is all on the device played through apples music app. Disabling Bluetooth then re-enabling it on the phone seems to be the way to get it back when it stops
I've been doing that but it usually just disconnects after a few songs again
Appreciate 0
      12-01-2020, 02:55 AM   #15
Prudvi_12
Enlisted Member
3
Rep
34
Posts

Drives: 2016 BMW f80 M3
Join Date: Jan 2020
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by M's ///M View Post
Do you have any other devices connected via Bluetooth, or simply paired to your phone when you run into this issue?

If you do, try completely removing all other paired devices (forget this device) and test with just the iDrive. If it works, begin pairing your other devices one by one and retesting after each device.

In my case, it would only begin failing after I paired this one particular device and thankfully it was a device I no longer used much so problem solved in my case.

Mo
I only have my phone paired currently, I'm gonna try it with a few different phone to see maybe if it's just my phone
Appreciate 0
      12-01-2020, 11:55 AM   #16
hC1001
Lieutenant
226
Rep
406
Posts

Drives: E36 M3, F80 M3
Join Date: Nov 2019
Location: Brooklyn, NY

iTrader: (2)

Have you guys tried updating the Idrive software? There are updates specific to connectivity issues. https://www.bmw.com/en/footer/software-updates.html
Appreciate 0
      12-01-2020, 07:35 PM   #17
simons22
New Member
2
Rep
6
Posts

Drives: BMW M5 2018
Join Date: Nov 2020
Location: New York

iTrader: (0)

Quote:
Have you guys tried updating the Idrive software? There are updates specific to connectivity issues. look herel
already installed it
works like a charm

Last edited by simons22; 12-08-2020 at 06:40 PM..
Appreciate 0
      12-01-2020, 11:12 PM   #18
Darkmann
Enlisted Member
17
Rep
47
Posts

Drives: F80 M3
Join Date: Apr 2020
Location: US - Maryland

iTrader: (0)

So I have been trying to find a pattern. Only thing I was able to duplicate is when my ESCORT RL 360c radar detector (RD) pairs with BlueTooth. The first time it paired, the system shut down SiriusXM but CarPlay stayed on the screen,..., just staring at me! When I tried again, CarPlay would pop-up and stay on screen, but SiriusXM would be playing in background. I unpaired my RD just before Thanksgiving and I haven't had the problem in either the X5 or the M3. I didn't think this was an iOS version thing, but I'm beginning to think it's more iOS version related than a BMW system issue.
Appreciate 0
      12-02-2020, 01:34 AM   #19
duky
The Tanzanian
duky's Avatar
United_States
984
Rep
1,305
Posts

Drives: BSM F80
Join Date: Jan 2012
Location: Oakland, CA

iTrader: (8)

Garage List
2016 BMW M3  [5.00]
Quote:
Originally Posted by hC1001 View Post
Have you guys tried updating the Idrive software? There are updates specific to connectivity issues. https://www.bmw.com/en/footer/software-updates.html
Says my car is up to date
__________________
Current: 2016 F80 Black Sapphire Metallic on Silverstone
Former: 2007 E90 335i Barbera Red on Terra Dakota
Appreciate 0
      12-02-2020, 01:29 PM   #20
Prudvi_12
Enlisted Member
3
Rep
34
Posts

Drives: 2016 BMW f80 M3
Join Date: Jan 2020
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Darkmann View Post
So I have been trying to find a pattern. Only thing I was able to duplicate is when my ESCORT RL 360c radar detector (RD) pairs with BlueTooth. The first time it paired, the system shut down SiriusXM but CarPlay stayed on the screen,..., just staring at me! When I tried again, CarPlay would pop-up and stay on screen, but SiriusXM would be playing in background. I unpaired my RD just before Thanksgiving and I haven't had the problem in either the X5 or the M3. I didn't think this was an iOS version thing, but I'm beginning to think it's more iOS version related than a BMW system issue.
That's very strange, does this happen often or did it only have the two times?
Appreciate 0
      12-02-2020, 01:30 PM   #21
Prudvi_12
Enlisted Member
3
Rep
34
Posts

Drives: 2016 BMW f80 M3
Join Date: Jan 2020
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by simons22 View Post
Quote:
Have you guys tried updating the Idrive software? There are updates specific to connectivity issues. https://www.bmw.com/en/footer/software-updates.html
already installed it
works like a charm
I tried and I believe it helped a bit bc it disconnects less often but still happens
Appreciate 0
      12-02-2020, 04:06 PM   #22
Darkmann
Enlisted Member
17
Rep
47
Posts

Drives: F80 M3
Join Date: Apr 2020
Location: US - Maryland

iTrader: (0)

Quote:
Originally Posted by Prudvi_12 View Post
That's very strange, does this happen often or did it only have the two times?
Strange, yes. No, I have not done the update - will perform on both vehicles this week.

I run SiriusXM most of the time. I noticed the issue a few weeks back. First, CarPlay would pop-up momentarily on screen and disappear. SiriusXM would continue in background. Sometime within past month, CarPlay would pop up, but then it would kick me out of SiriusXM. Sometimes my phone would just be on the charger and this would happen. Most times, my wife would be using phone and this would happen. Annoying was that on a 1-hr drive, it can do this up to 10 times - so annoying that would just turn off the radio. It happens on both my MY17 X5 and MY18 M3. On both vehicles, I run the ESCORT RL 360c or an iXc, both Bluetooth capable radar detectors.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:41 AM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST