BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics

Post Reply
 
Thread Tools Search this Thread
      12-13-2018, 08:39 AM   #1
DaytonaVioletM3
Private First Class
DaytonaVioletM3's Avatar
180
Rep
138
Posts

Drives: f80 M3 Competition
Join Date: Aug 2018
Location: Lehigh Valley

iTrader: (1)

FM/AM not working but everything else does

2017 F80, just noticed no AM/FM radio volume. Everything else works fine meaning music collection/aux. Any ideas? Thanks in advance
__________________
2017 Daytona Violet ZCP F80
Bm3 Stage 2
Appreciate 0
      12-13-2018, 10:43 PM   #2
IK6SPEED
Major General
IK6SPEED's Avatar
United_States
1316
Rep
7,005
Posts

Drives: BMW M3 / AH3
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (18)

Quote:
Originally Posted by DaytonaVioletM3 View Post
2017 F80, just noticed no AM/FM radio volume. Everything else works fine meaning music collection/aux. Any ideas? Thanks in advance
As you have 2017, seems Dealer will be replacing your NBT HU under warranty.
__________________
Stable: F80 / AH3
Past: F80 ZCP / F22 M235i / E89 35is
Appreciate 0
      12-14-2018, 07:17 AM   #3
DaytonaVioletM3
Private First Class
DaytonaVioletM3's Avatar
180
Rep
138
Posts

Drives: f80 M3 Competition
Join Date: Aug 2018
Location: Lehigh Valley

iTrader: (1)

Quote:
Originally Posted by IK6SPEED View Post
As you have 2017, seems Dealer will be replacing your NBT HU under warranty.

Thanks is this a common problem?
__________________
2017 Daytona Violet ZCP F80
Bm3 Stage 2
Appreciate 0
      12-14-2018, 09:12 AM   #4
IK6SPEED
Major General
IK6SPEED's Avatar
United_States
1316
Rep
7,005
Posts

Drives: BMW M3 / AH3
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (18)

Quote:
Originally Posted by DaytonaVioletM3 View Post
Quote:
Originally Posted by IK6SPEED View Post
As you have 2017, seems Dealer will be replacing your NBT HU under warranty.

Thanks is this a common problem?
No, not at all.

I don't recall another with this issue.
__________________
Stable: F80 / AH3
Past: F80 ZCP / F22 M235i / E89 35is
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:48 PM.




f80post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST