Autotalent
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Suspension | Brakes | Chassis

Post Reply
 
Thread Tools Search this Thread
      09-05-2018, 11:41 AM   #1
beyondtheabyss
Banned
United_States
60
Rep
179
Posts

Drives: 2015 Sakhir Orange M4
Join Date: Aug 2015
Location: Woodland Hills, CA

iTrader: (0)

Question Clunking Noise When Turning

Hey guys, just wondering if anyone is or has experienced what I'm going through now.

So about a week ago, after getting my car Ceramic Coated, I realized there was a knocking or clunking noise (that's the best I can describe the noise) coming from the front of the car. More specifically, the wheels. It only happens when I turn the wheel and I have to turn the wheel at least half way before the noise presents itself. Also only happens at low speeds. I thought that maybe it would go away on it's own but it seems like it's starting to get a little worse.

It hasn't affected the way the car drives, but the noise is starting to drive me nuts. I'm no mechanic, as a matter of fact, I'd say I'm a complete amateur when it comes down to the mechanics of cars but I want to say it has something to do with the control arms?

Has anyone else experienced this? Car is out of warranty so I can't take it in. Just wondering if anyone has any insight on what this could possibly be and should it be taken care of immediately or can I hold off on it for another couple weeks?

Thanks in advance!
Appreciate 0
      09-05-2018, 07:26 PM   #2
jdaustin
Enlisted Member
15
Rep
46
Posts

Drives: f82 m4
Join Date: May 2018
Location: CA

iTrader: (0)

Currently have the same issue, started happening after I swapped out brake pads
Appreciate 0
      09-05-2018, 09:01 PM   #3
domino_z
Lieutenant Colonel
Australia
1098
Rep
1,945
Posts

Drives: F80 CP
Join Date: Apr 2008
Location: Australia

iTrader: (0)

this has been reported a few times on the forum

happened to me too, within first 1000km, it's the top mounts

dealer replaced under warranty no issues

easiest way to diagnose, have someone move the steeringwheel with engine off (dry steer) left to right and put your hand on top of the top mount under bonnet, you will feel the click through your hand

dealer had no explanation for the why, other than to say heavy washing/degreasing under fenders washes away oe grease - lol they are a sealed bearing
Appreciate 0
      09-06-2018, 01:10 AM   #4
beyondtheabyss
Banned
United_States
60
Rep
179
Posts

Drives: 2015 Sakhir Orange M4
Join Date: Aug 2015
Location: Woodland Hills, CA

iTrader: (0)

Quote:
Originally Posted by domino_z View Post
this has been reported a few times on the forum

happened to me too, within first 1000km, it's the top mounts

dealer replaced under warranty no issues

easiest way to diagnose, have someone move the steeringwheel with engine off (dry steer) left to right and put your hand on top of the top mount under bonnet, you will feel the click through your hand

dealer had no explanation for the why, other than to say heavy washing/degreasing under fenders washes away oe grease - lol they are a sealed bearing
Ah, gotcha. Okay good to know! So it's a relatively easy and inexpensive fix right? Seems like it would be.

Thanks again for your help! I couldn't find any other posts on this but I'm glad that I'm not the only one experiencing this.
Appreciate 0
Post Reply

Bookmarks

Tags
clunk, knocking, noise, steering

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:40 PM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST