Fi Exhaust
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Engine / Drivetrain / Exhaust / Bolt-ons / Tuning

Post Reply
 
Thread Tools Search this Thread
      06-13-2021, 03:49 PM   #1
M4_castro
New Member
0
Rep
7
Posts

Drives: 2015 bmw m4
Join Date: Oct 2020
Location: New york

iTrader: (0)

Help ! Dct making a double downshift sound!!

Has anyone experienced a problem where the car would make a double downshift noise from 3rd to second even though it's only downshifting 1 time ? Seems like a hesitation with rev matching where it feels as if it's miscalculating it and having to rev match again . Pls help if anyone has encountered the same problem !!
Appreciate 0
      06-13-2021, 05:06 PM   #2
M4_castro
New Member
0
Rep
7
Posts

Drives: 2015 bmw m4
Join Date: Oct 2020
Location: New york

iTrader: (0)

Bump
Appreciate 0
      06-13-2021, 05:22 PM   #3
FriedPiston
Colonel
United_States
1531
Rep
2,503
Posts

Drives: Scraper
Join Date: Oct 2013
Location: East Oakland, CA

iTrader: (24)

Need more info like the ones below:

Engine Mode: Efficient, Sport, Sport+
DCT Mode: D, S, Manual
DriveLogic Level: I, II, III
Engine Tune: Stock, OTS, Custom
DCT Calibration: Stock, GTS/CS, xHP
Clutchpack: Stock, Aftermarket

This happened to me earlier while crusing at 25mph to warm up the car. Engine was in Efficient, Transmission set to Manual with DriveLogic II. Other mods are xHP Stage 3 (v.12) with Dodson Sportsman clutchpack.

Issue: Coming into a slow rolling stop, the transmission went from 3rd to 2nd, then went into 1st as soon as I started to accelerate.

Fix attempt: Re-flashed xHP v1.2 with Stock ShiftMaps; will need to continue to observe for recurring shift behavior.
Appreciate 0
      06-13-2021, 05:28 PM   #4
M4_castro
New Member
0
Rep
7
Posts

Drives: 2015 bmw m4
Join Date: Oct 2020
Location: New york

iTrader: (0)

Quote:
Originally Posted by FriedPiston View Post
Need more info like the ones below:

Engine Mode: Efficient, Sport, Sport+
DCT Mode: D, S, Manual
DriveLogic Level: I, II, III
Engine Tune: Stock, OTS, Custom
DCT Calibration: Stock, GTS/CS, xHP
Clutchpack: Stock, Aftermarket

This happened to me earlier while crusing at 25mph to warm up the car. Engine was in Efficient, Transmission set to Manual with DriveLogic II. Other mods are xHP Stage 3 (v.12) with Dodson Sportsman clutchpack.

Issue: Coming into a slow rolling stop, the transmission went from 3rd to 2nd, then went into 1st as soon as I started to accelerate.

Fix attempt: Re-flashed xHP v1.2 with Stock ShiftMaps; will need to continue to observe for recurring shift behavior.
This is when it occurs , car seems 100% fine when letting car shift automatic . Also noticing the clutch loses the gear and then catches it when I shift again . So weird because the car hasn't been pushed which is why I'm trying to cancel out the clutches being bad .

Engine Mode: Sport+
DCT Mode: Manual
DriveLogic Level: I, II, III
Engine Tune: OTS
DCT Calibration: GTS/CS
Clutchpack: Stock
Appreciate 0
      06-13-2021, 05:30 PM   #5
FriedPiston
Colonel
United_States
1531
Rep
2,503
Posts

Drives: Scraper
Join Date: Oct 2013
Location: East Oakland, CA

iTrader: (24)

Quote:
Originally Posted by M4_castro View Post
This is when it occurs , car seems 100% fine when letting car shift automatic . Also noticing the clutch loses the gear and then catches it when I shift again . So weird because the car hasn't been pushed which is why I'm trying to cancel out the clutches being bad .

Engine Mode: Sport+
DCT Mode: Manual
DriveLogic Level: I, II, III
Engine Tune: OTS
DCT Calibration: GTS/CS
Clutchpack: Stock
Engine in Sport+ will make the shift points more aggressive, so it sounds completely normal. Which DriveLogic level (I, II or III) were you using? That may further explain what happened.
Appreciate 0
      06-13-2021, 05:34 PM   #6
M4_castro
New Member
0
Rep
7
Posts

Drives: 2015 bmw m4
Join Date: Oct 2020
Location: New york

iTrader: (0)

Quote:
Originally Posted by FriedPiston View Post
Quote:
Originally Posted by M4_castro View Post
This is when it occurs , car seems 100% fine when letting car shift automatic . Also noticing the clutch loses the gear and then catches it when I shift again . So weird because the car hasn't been pushed which is why I'm trying to cancel out the clutches being bad .

Engine Mode: Sport+
DCT Mode: Manual
DriveLogic Level: I, II, III
Engine Tune: OTS
DCT Calibration: GTS/CS
Clutchpack: Stock
Engine in Sport+ will make the shift points more aggressive, so it sounds completely normal. Which DriveLogic level (I, II or III) were you using? That may further explain what happened.
Happens on drivelogic I,II and III.
Appreciate 0
      06-13-2021, 05:43 PM   #7
FriedPiston
Colonel
United_States
1531
Rep
2,503
Posts

Drives: Scraper
Join Date: Oct 2013
Location: East Oakland, CA

iTrader: (24)

doh! sounds completely normal. My recommendation is to drive exclusively in Manual mode with DriveLogic II. It makes the DCT feel more fun and engaging... the only time I let the computer shift for me is when I'm eating on a long road trip. Otherwise, the DCT is best driven like a manual transmission less a clutch pedal.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:22 AM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST