VIBE Motorsports
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Engine / Drivetrain / Exhaust / Bolt-ons / Tuning

Post Reply
 
Thread Tools Search this Thread
      06-26-2016, 03:08 PM   #45
lewz4
Private First Class
lewz4's Avatar
United_States
27
Rep
119
Posts

Drives: shopping cart
Join Date: Aug 2013
Location: socal

iTrader: (2)

I just got a UCP installed and my rev-matching is kinda laggy now when before the install, it was working 100%. Does anyone else have a UCP and experience this as well?
Appreciate 0
      06-26-2016, 04:34 PM   #46
Jockey
Brigadier General
Jockey's Avatar
United_States
2566
Rep
4,685
Posts

Drives: F80 SS/SS M3
Join Date: Mar 2008
Location: Park City, UT

iTrader: (1)

Hmm, maybe this is what can get me the 58.3 upgrade.
Appreciate 0
      08-23-2016, 04:08 PM   #47
zillymc
Private First Class
zillymc's Avatar
74
Rep
109
Posts

Drives: 2018 BMW M3 | Tanzanite
Join Date: Oct 2015
Location: Los Gatos, CA

iTrader: (0)

Had my car for 10K and havent noticed any issues with rev matching, 2016 M4 build date July 2015
__________________
New: 2018 M3 ZCP Tanzanite / 6MT
Old: 2016 M4 / Yas Marina Blue / 6MT / Dinan Stage 1 / EDC / Black Kidney Grilles / MPerf CF Spoiler / Exec Pack
Appreciate 0
      08-23-2016, 08:43 PM   #48
Jockey
Brigadier General
Jockey's Avatar
United_States
2566
Rep
4,685
Posts

Drives: F80 SS/SS M3
Join Date: Mar 2008
Location: Park City, UT

iTrader: (1)

Damnit, forget to bring this up at the dealer today. And they had the damn car for two days.
Appreciate 0
      08-24-2016, 12:33 PM   #49
JoeFromPA
Colonel
1647
Rep
2,967
Posts

Drives: '15 AW M3 6MT Stripper
Join Date: Aug 2013
Location: SE PA

iTrader: (0)

24k miles, never a single issue with rev-match except sometimes it's supposed to and it doesn't (i.e. coasting in neutral and suddenly go to put it in 2nd gear, and it won't). Of course that's fixed by a little throttle blip.

2 years old as of 2 days ago
Appreciate 0
      08-26-2016, 12:11 AM   #50
FR00ZN
Private
FR00ZN's Avatar
22
Rep
78
Posts

Drives: F80 BMW M3
Join Date: Nov 2015
Location: Sydney, Australia

iTrader: (0)

I have found that it depends on how far down i depress the clutch. So if i was in eco or sport mode, it rev matches, then when i go into s+ i can have rev matching if i depress the clutch most of the way down, not all the way to the end point of travel. Once i depress all the way to end point (i have the bms clutch stop) then it will stop rev matching.

I can achieve no rev match in eco and sport mode by doing the same thing in reverse. So if i'm in sport+ with no rev match, then select either of the other modes and change gear without depressing the clutch all the way (its hard to say how far down, but enough to change gear without touching the end point of travel) then i can change gear in those modes without any rev matching.

I wanted to actually take a look under the console to see if there is a sensor there, perhaps the same one which needs to be engaged to start the car by depressing the clutch all the way down. For example, i can push the clutch down to just above the clutch stop and the car wont start, i push just a little more where i can feel the clutch pedal touching the clutch stop and the car will start. I'm thinking that whatever sensor is used for this is the same one used to tell the car to rev match in certain modes.

Just my personal experience
Appreciate 0
      09-02-2016, 12:58 PM   #51
bd307
Chef
bd307's Avatar
889
Rep
1,061
Posts

Drives: Things with wheels or no wheel
Join Date: Dec 2014
Location: Area 51

iTrader: (0)

Quote:
Originally Posted by FR00ZN View Post
I have found that it depends on how far down i depress the clutch. So if i was in eco or sport mode, it rev matches, then when i go into s+ i can have rev matching if i depress the clutch most of the way down, not all the way to the end point of travel. Once i depress all the way to end point (i have the bms clutch stop) then it will stop rev matching.

I can achieve no rev match in eco and sport mode by doing the same thing in reverse. So if i'm in sport+ with no rev match, then select either of the other modes and change gear without depressing the clutch all the way (its hard to say how far down, but enough to change gear without touching the end point of travel) then i can change gear in those modes without any rev matching.

I wanted to actually take a look under the console to see if there is a sensor there, perhaps the same one which needs to be engaged to start the car by depressing the clutch all the way down. For example, i can push the clutch down to just above the clutch stop and the car wont start, i push just a little more where i can feel the clutch pedal touching the clutch stop and the car will start. I'm thinking that whatever sensor is used for this is the same one used to tell the car to rev match in certain modes.

Just my personal experience
Please report back if you find out anything. This is interesting.
Appreciate 0
      11-27-2016, 12:19 AM   #52
NewM3driver
Colonel
1052
Rep
2,010
Posts

Drives: 2017 M3 ZCP
Join Date: Nov 2008
Location: CT

iTrader: (0)

Rev match question

Do you guys with the 6 speed manual ALWAYS get a rev match every single time in efficient and sport, and NEVER get a rev match EVER in sport plus?
Appreciate 0
      11-27-2016, 12:31 AM   #53
al3xander
Lieutenant
al3xander's Avatar
United_States
374
Rep
533
Posts

Drives: 2018 F80 M3
Join Date: Jul 2010
Location: Chicago

iTrader: (1)

Correct, efficient and sport always rev match. Sport plus does not have rev match.
Appreciate 1
Agent11br439.00

      11-27-2016, 12:34 AM   #54
NewM3driver
Colonel
1052
Rep
2,010
Posts

Drives: 2017 M3 ZCP
Join Date: Nov 2008
Location: CT

iTrader: (0)

Quote:
Originally Posted by al3xander View Post
Correct, efficient and sport always rev match. Sport plus does not have rev match.
And the car never misses either way? Both my cars will miss a rev match now and then
Appreciate 0
      11-27-2016, 12:45 AM   #55
M-Pilot
Brigadier General
M-Pilot's Avatar
United_States
4631
Rep
3,644
Posts

Drives: 981 Cayman GTS
Join Date: Mar 2015
Location: CA

iTrader: (0)

During my 5 months of ownership, I haven't seen a missed rev match yet. However, if I hold the clutch in way too long (e.g. A few seconds), it won't rev match. As long as you release the clutch right after the downshift, it should rev match.
Appreciate 0
      11-29-2016, 02:01 PM   #56
shiv.nandak
Lieutenant
264
Rep
479
Posts

Drives: C7 Z06, 16' M4 6MT SO
Join Date: May 2013
Location: Pittsburgh

iTrader: (0)

For the guys that are having issues with rev matching - do you usually:

1) Clutch in, immediately down-shift

or

2) Clutch in while slowing down, wait some time and then down-shift?
Appreciate 0
      11-29-2016, 02:05 PM   #57
dmk08
Mask Up and Wash Yo Hands
dmk08's Avatar
United_States
5226
Rep
11,351
Posts

Drives: Walks
Join Date: Jul 2012
Location: Atlanta

iTrader: (19)

I had some of the oddities on my 15 but none at all on my 16. Guessing they cleaned something up in the code.
Appreciate 0
      11-29-2016, 08:43 PM   #58
scott13
First Lieutenant
scott13's Avatar
295
Rep
332
Posts

Drives: 2020 M4 | BSM | 6MT
Join Date: May 2015
Location: New England (Boston Area)

iTrader: (0)

Quote:
Originally Posted by dmk08 View Post
The only problem I have had with rev match is sometimes in sport mode it will randomly rev match on an upshift.
Same here. I have ~20k miles on a MY15 and have had zero issues when in Sport+. I do, however, get sporadic rev blips on upshifts in Sport, but only going from 4th to 5th. Not really a problem, but definitely weird.
Appreciate 0
      12-19-2016, 10:19 PM   #59
MichaelMichaels
New Member
3
Rep
11
Posts

Drives: M4 Dinan Stage 2
Join Date: Apr 2016
Location: Los Angeles

iTrader: (0)

Whats With 6MT Rev Matching Sometimes Working in Sport+ mode?

I searched and have seen some discussion on this but no real answer. So as most of you know with manual transmissions, the rev matching ALWAYS works when you don't have Sport+ engaged. Anyway, today I noticed on my M4 that the downshift revmatching was working in Sport+ mode. I turned off the car/started it several times and it kept working. Before when I noticed it was working in Sport+ mode, it would stop next time I started the car. So more than likely tomorrow morning when I start it, it won't work in Sport+ mode again.

So basically, what the hell is the deal with this? Wouldn't it make more sense to be an option, or at least NOT do it in non-Sport+ modes and only do it in Sport+ modes? Just odd it sometimes chooses to work in Sport+ mode. Anyway, thanks.
Appreciate 0
      12-20-2016, 02:42 AM   #60
M-Pilot
Brigadier General
M-Pilot's Avatar
United_States
4631
Rep
3,644
Posts

Drives: 981 Cayman GTS
Join Date: Mar 2015
Location: CA

iTrader: (0)

Maybe you need a software update. I have late 2016 ZCP and I haven't seen any instance yet where rev match didn't work in sport/efficient (or randomly worked in sport+).
Appreciate 0
      12-20-2016, 02:45 AM   #61
ElSenor
Second Lieutenant
131
Rep
237
Posts

Drives: 16' AW/SO M3
Join Date: Oct 2015
Location: Stuttgart, Germany

iTrader: (0)

mine has never worked on sport+...I wish it did
Appreciate 1
duky948.50

      12-20-2016, 05:44 AM   #62
trey100
Colonel
trey100's Avatar
799
Rep
2,294
Posts

Drives: 2016 M3 6MT
Join Date: Jul 2007
Location: New York

iTrader: (0)

8,500 miles so far and I haven't had rev match work in sport+
Appreciate 0
      12-20-2016, 08:22 AM   #63
Jockey
Brigadier General
Jockey's Avatar
United_States
2566
Rep
4,685
Posts

Drives: F80 SS/SS M3
Join Date: Mar 2008
Location: Park City, UT

iTrader: (1)

I've had both happen. It's becoming more and more often that rev matching won't work in sport. I can always tell too, there is a different feel on the upshift to 5th gear sometimes, sure as hell, downshift back and no rev match.

I don't DD in sport+ much but have had rev match happen there as well.
Appreciate 0
      12-20-2016, 09:30 AM   #64
gatorfast
Major General
gatorfast's Avatar
United_States
3622
Rep
6,468
Posts

Drives: 718 Cayman
Join Date: Jan 2008
Location: SoFla

iTrader: (4)

Quote:
Originally Posted by kitesurfer View Post
here is a video of another forum member having issues with his car rev matching in sport +,. this is similar to what I have experienced

The main thing I see wrong in this video is the driver hitting high rpm's and going wot before the engine is warmed up
Appreciate 0
      12-20-2016, 12:14 PM   #65
Ian1973
Colonel
727
Rep
2,134
Posts

Drives: 15 M3
Join Date: Sep 2013
Location: Charlton, NY

iTrader: (0)

18 months or so and 28,000 miles with mine and I have never experienced any issues with rev matching. I do not use the sport+ mode often as I've found I'm simply commuting more than driving for fun as of late.
Appreciate 0
      12-20-2016, 02:27 PM   #66
schnell1982
Captain
315
Rep
931
Posts

Drives: FAST
Join Date: Dec 2015
Location: Southern California

iTrader: (0)

Quote:
Originally Posted by NewM3driver View Post
Do you guys with the 6 speed manual ALWAYS get a rev match every single time in efficient and sport, and NEVER get a rev match EVER in sport plus?
Yes I get the same result.
Never rev match in Sport +

Honestly, I don't care for the revmatch. Its too much sometimes in eco mode when I just want to cruise thru town...then again I should of probably got a quieter exhaust lol
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:45 AM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST