BPM
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > DIY and Coding Discussions

Post Reply
 
Thread Tools Search this Thread
      12-31-2018, 05:12 PM   #111
S1000RR_Neil
Registered
0
Rep
4
Posts

Drives: F83 M4 Vert
Join Date: Dec 2018
Location: UK

iTrader: (0)

Hey guys,

Just joined the site - been on the scene for a while either on the rest of the sites available (without naming them ) or by just reading/ researching on here.

I had a query flashing my F83 3U92 vert with F82 4S92 and hoped you could help steer me.. (it might be there's nothing wrong)

I recently flashed all modules to the latest 18-11-531 psdzdata with no problems.

I wanted to see what differences the GTS flash might make - although when I filter my tal-processing to EGS4/EPS/GHAS - and run the flashing process - it completes in 1 second 'successfully'. it doesn't actually begin processing the update!?

I thought it could be due to other dependencies - yet none of the modules have any prerequisites?

It's suggesting 13 updates with the F82 4S92 selected and I'm just choosing the aforementioned modules.

Could it be my psdzdata is later than the available GTS files?
Appreciate 0
      01-10-2019, 06:38 PM   #112
kubax86
BimmerPost Supporting Vendor
kubax86's Avatar
Germany
461
Rep
891
Posts


Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (3)

Hello,
Can't calculate proper swfl with newest e sys(3.30). Solution is to use older version like 3.27.1)?

Thanks
Appreciate 0
      01-11-2019, 01:30 AM   #113
Almaretto
Major General
Almaretto's Avatar
United_States
1989
Rep
7,825
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by kubax86 View Post
Hello,
Can't calculate proper swfl with newest e sys(3.30). Solution is to use older version like 3.27.1)?

Thanks
Works fine on 3.33
Appreciate 0
      01-12-2019, 06:15 AM   #114
kubax86
BimmerPost Supporting Vendor
kubax86's Avatar
Germany
461
Rep
891
Posts


Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (3)

Quote:
Originally Posted by Almaretto View Post
Works fine on 3.33
TAL CALCULATING
READ FA
CHANGE TYPECODE TO 4S93(CALCULATE FP)
SAVE SVT ACTUAL AS SVT_IST
THEN COMPLETE FLASH
SAVE SVT_SOLL

And it only wants to flash HU_NBT which is bullshit.
What am i doing wrong?

Thanks
Appreciate 0
      01-12-2019, 06:32 AM   #115
Almaretto
Major General
Almaretto's Avatar
United_States
1989
Rep
7,825
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by kubax86 View Post
TAL CALCULATING
READ FA
CHANGE TYPECODE TO 4S93(CALCULATE FP)
SAVE SVT ACTUAL AS SVT_IST
THEN COMPLETE FLASH
SAVE SVT_SOLL

And it only wants to flash HU_NBT which is bullshit.
What am i doing wrong?

Thanks
Not sure based on that limited information.
Appreciate 0
      01-12-2019, 07:29 AM   #116
kubax86
BimmerPost Supporting Vendor
kubax86's Avatar
Germany
461
Rep
891
Posts


Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (3)

Quote:
Originally Posted by Almaretto View Post
Not sure based on that limited information.

What information u need?
Calculated svts and tal?
Appreciate 0
      01-12-2019, 07:51 AM   #117
Almaretto
Major General
Almaretto's Avatar
United_States
1989
Rep
7,825
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by kubax86 View Post
What information u need?
Calculated svts and tal?
FA & SVT. Calculated may also help.
Appreciate 0
      01-22-2019, 04:28 PM   #118
Nicky888
Registered
0
Rep
4
Posts

Drives: M135i
Join Date: Aug 2018
Location: East Midlands

iTrader: (0)

Quote:
Originally Posted by ACCENG View Post
I have successfully updated (flashed) several modules on the car to be able to vo code everything to gts. I have updated DME, EPS, GHAS, DSC, and ICM to the latest version following the esys software update guide. Then I vo coded EPS, GHAS, and DSC to GTS by changing my FA to 4S93 and build date to 0717. I have tried multiple times to flash the EGS. But when I calculate under KIS/SVT Target, I am not getting any software to flash the EGS and it flashes in one second. When I do not modify the FA I get a new version to flash so not understanding what I am doing wrong. My Istep is very old F020-14-11-502, not sure if that has anything to do with the issues I am having. Any help would be greatly appreciated.

Hi mate, i have a 135i, F20. 64 plate. I also want to update dme, eps, ghas, dsc and icm. Did you update all at once? And did you get any errors? Also did you have to check prerequisites/dependencies or do these ECUís not have any? I also understand a power supply to the battery is required...did you connect one for these specific ecu updates? Any help would be appriciated
Appreciate 0
      01-29-2019, 07:03 PM   #119
kubax86
BimmerPost Supporting Vendor
kubax86's Avatar
Germany
461
Rep
891
Posts


Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (3)

Quote:
Originally Posted by Steveo View Post
Hmmm,

Not sure what Iím doing wrong then.
Car is an F87 M2 LCI with shipment 17-11-540 but recently whole car updated to 18-07-531
Still using same data set 18-07-531

Connected to car, read FA and saved then edited to change type to 4S91 euro GTS. Saved.
Had to remove option 687 as error came up during calculation.
Read Actual SVT and saved.
Selected complete flash.
Done calculation and itís looking to update just the NBT unit....

Any ideas?
Got the same problem, but i thought, wait, when was the end production of M4 GTS and what could be the highest shipment level?
That was solution to my calculation problem
After figuring out right shipment level, I was able to flash my EGS with GTS swfl(38c2). I was on 18-11-531, then flashed only swfl and the difference is noticeable(less jerkines, smoother shifts etc.)

If someone needs help fell free to ask.
Appreciate 0
      11-03-2019, 03:02 AM   #120
Dangriffin87
Private
3
Rep
61
Posts

Drives: BMW M3 80
Join Date: Oct 2016
Location: Perth Australia

iTrader: (0)

Guys, I am completely new to this, any chance someone can walk me through exactly what needs to be done here from step 1 to completion
Appreciate 0
      11-07-2019, 12:57 AM   #121
Almaretto
Major General
Almaretto's Avatar
United_States
1989
Rep
7,825
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by Dangriffin87 View Post
Guys, I am completely new to this, any chance someone can walk me through exactly what needs to be done here from step 1 to completion
Details are are thread.
Appreciate 0
      11-24-2019, 02:37 PM   #122
S1000RR_Neil
Registered
0
Rep
4
Posts

Drives: F83 M4 Vert
Join Date: Dec 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by Almaretto View Post
Has a cabrio or coupe?

Hey Almaretto,


Iíve tried it a few times with the cabrio (vert) and its doing the same.
Iíve tried different build dates and removed options - is thereís something else somewhere reiterating the cabrio setup?

Thanks for your help 🙏🙏🙏
Appreciate 0
      11-24-2019, 02:55 PM   #123
kubax86
BimmerPost Supporting Vendor
kubax86's Avatar
Germany
461
Rep
891
Posts


Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (3)

Use F082, not F083.
There is no F083 GTS.
Appreciate 0
      11-24-2019, 03:08 PM   #124
S1000RR_Neil
Registered
0
Rep
4
Posts

Drives: F83 M4 Vert
Join Date: Dec 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by kubax86 View Post
Use F082, not F083.
There is no F083 GTS.

Iím using F082 & 4S91 for EU.
Iím saving and loading the FA and activating before I compare to my actual SVT; but Iím not getting any changes to flash...
Appreciate 0
      11-24-2019, 03:22 PM   #125
kubax86
BimmerPost Supporting Vendor
kubax86's Avatar
Germany
461
Rep
891
Posts


Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (3)

Quote:
Originally Posted by S1000RR_Neil View Post
Iím using F082 & 4S91 for EU.
Iím saving and loading the FA and activating before I compare to my actual SVT; but Iím not getting any changes to flash...
iLevel shipment is your key.
Appreciate 0
      11-27-2019, 08:02 AM   #126
sna66
Lieutenant
sna66's Avatar
United_States
281
Rep
515
Posts

Drives: F83 SS on SS
Join Date: May 2014
Location: South FL

iTrader: (0)

Pardon my ignorance, how is this different from flashing the gts with bootmod3?
Appreciate 0
      11-27-2019, 11:22 AM   #127
cossie1
Captain
United Kingdom
450
Rep
839
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by sna66 View Post
Pardon my ignorance, how is this different from flashing the gts with bootmod3?
End result is the same, this is just a way of doing it, if you don't have a BM3 licence.
Appreciate 0
      11-27-2019, 10:36 PM   #128
sna66
Lieutenant
sna66's Avatar
United_States
281
Rep
515
Posts

Drives: F83 SS on SS
Join Date: May 2014
Location: South FL

iTrader: (0)

Quote:
Originally Posted by cossie1 View Post
Quote:
Originally Posted by sna66 View Post
Pardon my ignorance, how is this different from flashing the gts with bootmod3?
End result is the same, this is just a way of doing it, if you don't have a BM3 licence.
Thanks for clearing up bud, I guess I just wanted clarification that the bm3 flash is equal to the stock GTS, and not "close enough" to it.
Appreciate 0
      11-28-2019, 07:09 AM   #129
cossie1
Captain
United Kingdom
450
Rep
839
Posts

Drives: 2015 F82 M4
Join Date: Nov 2018
Location: UK

iTrader: (0)

Quote:
Originally Posted by sna66 View Post
Thanks for clearing up bud, I guess I just wanted clarification that the bm3 flash is equal to the stock GTS, and not "close enough" to it.
As far as I am aware, it is the same.
Appreciate 1
yayaya89.00

      12-10-2019, 03:26 PM   #130
H3685
New Member
3
Rep
14
Posts

Drives: BMW
Join Date: Jun 2015
Location: Monaco

iTrader: (0)

Anyone ever had the following isue:

EGS/GTS Flash done with software F020-19-07-562
Istep shipment F020-15-11-502
Istep current F020-19-03-546

Old standard file: SWFL_00001F70_000_056_000
GTS proposed file: SWFL_000034E2_000_056_000

Flash is 100% without faults. I didn't do any VO coding.
Remarkable is that there is no green cafd file under EGS4. When I try to "detect CAF for SWE" I get the message:
no cafd-mapping fore base variant
Deleting fault codes from car. No faults left (only 1 code about the chiptuning 201101. Was there before flash)
I drive backwards out of the garage, no problem. It feels better when taking off in reverse.
When I put the stick in D it gives drivetrain faults.
The light in the gearstick is NOT lighting up (middle light and D/S).
D is not showed on the dashboard.

When I read the codes with ISTA/D I get a KOMBI code:
Invalid signal (power train data display, 0x3FD), transmitter EGS/DCT/EME

With the original software back on the EGS its working perfect again.
Anyone any idea?
Appreciate 0
      12-10-2019, 05:47 PM   #131
kubax86
BimmerPost Supporting Vendor
kubax86's Avatar
Germany
461
Rep
891
Posts


Drives: M4
Join Date: Jul 2017
Location: World

iTrader: (3)

Quote:
Originally Posted by H3685 View Post
Anyone ever had the following isue:

EGS/GTS Flash done with software F020-19-07-562
Istep shipment F020-15-11-502
Istep current F020-19-03-546

Old standard file: SWFL_00001F70_000_056_000
GTS proposed file: SWFL_000034E2_000_056_000

Flash is 100% without faults. I didn't do any VO coding.
Remarkable is that there is no green cafd file under EGS4. When I try to "detect CAF for SWE" I get the message:
no cafd-mapping fore base variant
Deleting fault codes from car. No faults left (only 1 code about the chiptuning 201101. Was there before flash)
I drive backwards out of the garage, no problem. It feels better when taking off in reverse.
When I put the stick in D it gives drivetrain faults.
The light in the gearstick is NOT lighting up (middle light and D/S).
D is not showed on the dashboard.

When I read the codes with ISTA/D I get a KOMBI code:
Invalid signal (power train data display, 0x3FD), transmitter EGS/DCT/EME

With the original software back on the EGS its working perfect again.
Anyone any idea?

This SWFL_000034E2_000_056_000 is NOT GTS Software. That's why you're getting errors.

EGS4 doesn't have coding data(CAFD). Only BTLD, HWEL and 2 SWFL.
__________________
Apple CarPlay for NBT EVO/ENTRYNAV2/MGU (iDrive 5/6/7)
Fullscreen CarPlay Patch for EVO and WAY, Region Changes, Map lifetime Codes, All FSCs, Remote Coding Services

oempackbmw@gmail.com or PM
Appreciate 0
      12-11-2019, 02:33 AM   #132
H3685
New Member
3
Rep
14
Posts

Drives: BMW
Join Date: Jun 2015
Location: Monaco

iTrader: (0)

Quote:
Originally Posted by kubax86 View Post
This SWFL_000034E2_000_056_000 is NOT GTS Software. That's why you're getting errors.

EGS4 doesn't have coding data(CAFD). Only BTLD, HWEL and 2 SWFL.
Hmmm. That means something is going wrong with calculating the correct files.
Is there only one gts file available all over the different istep versions? (000038c1)
Appreciate 0
Post Reply

Bookmarks

Tags
dct, flashing, gts

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:44 AM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST