BPM
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics

Post Reply
 
Thread Tools Search this Thread
      08-07-2019, 07:32 PM   #1
F82///M
Private
Canada
18
Rep
60
Posts

Drives: '18 M4
Join Date: Sep 2018
Location: AB, Canada

iTrader: (0)

Rennline Phone Mount, gap with full leather interior

Finally received phone mount. Rennline lost the package (it didn't get picked up by DHL 19 days after receiving tracking info) and ignored refund request multiple times. After opening PayPal claim got the refund and ordered from Pelican Parts, Ecs tuning was out of stock.


Got it installed and here we go, beautiful gap. I've seen few users complaining about it and it seems like a leather is to blame. All those with regular dash don't have a gap because it's soft and it gets pushed in.


Didn't wanna send it back so I started trimming the mount. Piece closest to the bottom hole was mostly in the way. Ended up cutting it off completely and trimmed few millimeters around the lineup hole where plastic piece from the back of the radio unit goes in. In the end gap is still present, at least this time for the thickness of the mount. Mount is sturdy, holds the phone in place and can't tell it's missing bottom piece. Upper bolt and lineup hole keeps it in place.

This was done on 2018 M4. Ambient lighting seems to be just a bit more illuminated around climate control due to the gap.

Pictures are in the order with the last one as a final result. In test fit pictures it may look like there's no need for cutting but when mount gets placed into the back of climate control the whole thing shifts 2mm towards the passenger side.
Attached Images
        
Appreciate 1
maniz562.50

      08-09-2019, 10:31 AM   #2
Nonopr01
Lieutenant
100
Rep
522
Posts

Drives: 2017 BMW M3
Join Date: Aug 2015
Location: San Juan, PR

iTrader: (0)

Only problem with this one is that it vibrates a lot. Difficult to focus.
Appreciate 0
      08-10-2019, 12:31 AM   #3
F82///M
Private
Canada
18
Rep
60
Posts

Drives: '18 M4
Join Date: Sep 2018
Location: AB, Canada

iTrader: (0)

Quote:
Originally Posted by Nonopr01 View Post
Only problem with this one is that it vibrates a lot. Difficult to focus.
Mine doesn't vibrate at all, even without bottom piece of the mount it's still tight. I have metal plate on the bottom of my phone so I can still use wireless charging at home and it's been holding up good on rough roads. Phone is LG G8 which is a bit bulky and on heavy side along with the protection case but it doesn't move.


On the other note I made this post hoping others would chime in if they're having a gap or not with info about the vehicle year/model/full leather dash or not.
Other than that, I'm satisfied with the mount even after small modification and small gap it still delivers.
Appreciate 0
      01-02-2020, 04:34 PM   #4
The_Pippin
New Member
2
Rep
7
Posts

Drives: 2016 BMW M3
Join Date: Jan 2020
Location: Raleigh, NC

iTrader: (0)

Hey man,

I know this is months later but I'm having the same issue. I like the mount and I tried to bend it a bit more but it still doesn't sit flush.

I have a 2016 M3 and full leather interior as well.

Last edited by The_Pippin; 01-02-2020 at 04:40 PM..
Appreciate 0
      01-06-2020, 11:22 PM   #5
hworang00
New Member
United_States
4
Rep
14
Posts

Drives: F80 M3
Join Date: May 2015
Location: Baltimore, MD

iTrader: (0)

I just got it and had to cut away some of the mount, and it still doesn't sit flush...I'm just going to live with it, but mine seems to vibrate a lot. I haven't driven it yet but just sitting in the car and flicking it (that sounds wrong), it vibrates quite a bit. Maybe I need to cut a little more off of it to make it sit flush for it to not vibrate? Anyone have any helpful input? Thank you!
Appreciate 0
      01-07-2020, 09:47 PM   #6
The_Pippin
New Member
2
Rep
7
Posts

Drives: 2016 BMW M3
Join Date: Jan 2020
Location: Raleigh, NC

iTrader: (0)

I emailed Rennline support and they are sending me another phone mount to see if it will fit better. They told me they make one mount for F30/F80/F82, but I'm hoping they have a more specific one for F80/F82 that may fit a little better.

Doesn't hurt to try
Appreciate 0
      01-08-2020, 07:57 PM   #7
hworang00
New Member
United_States
4
Rep
14
Posts

Drives: F80 M3
Join Date: May 2015
Location: Baltimore, MD

iTrader: (0)

I already cut mine though :\ I ordered the F30 one and it still has that gap
Appreciate 0
      02-03-2020, 09:13 PM   #8
Danlnyc88
Private First Class
100
Rep
154
Posts

Drives: 2020 M4
Join Date: Jun 2019
Location: Orange County

iTrader: (1)

Honestly doesn't bother me that much though. I cant even tell most of the time. Have u guys tried adding a washer or something to the left side to even it out that way?
Appreciate 0
      03-22-2020, 11:33 PM   #9
maniz
Assistant TO the Regional Manager
maniz's Avatar
United_States
563
Rep
705
Posts

Drives: 2018 M4 Coupe
Join Date: Mar 2014
Location: Denver

iTrader: (0)

Reviving the thread.

Just installed my Rennline mount. Same problem. And I don't even have the full leather dash. I have written to them.

Surprised this hasn't come up more often. Even the YouTube videos for F8X don't mention it. Either the problem is extremely limited or people aren't noticing it. I re-watched the Kies install video after discovering my issue and of course only then noticed the same gap in his install too. See the before/after comparison in the screenshots attached here. I know the camera moved slightly lower in the "after" pic but if you watch the video, there is clearly a gap after the install that wasn't there before.

Buyer beware on this one.
Attached Images
  
__________________
2018 M4 Coupe. 6MT.

Der stärkste buchstabe der welt

Last edited by maniz; 03-22-2020 at 11:46 PM..
Appreciate 0
      03-24-2020, 04:57 PM   #10
hC1001
Private
21
Rep
67
Posts

Drives: E36 M3, F80 M3
Join Date: Nov 2019
Location: Brooklyn, NY

iTrader: (0)

I also have a gap. You can tell you have a gap when you try to reinstall the bottom plastic cover and the right side is sorta tight but the left side clips in fine.

I can live with it but if anyone has a fix, i am willing to listen.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:16 PM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST