GetBMWParts
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > DIY and Coding Discussions

Post Reply
 
Thread Tools Search this Thread
      09-19-2019, 05:33 PM   #1497
itrocks4u
Colonel
United_States
301
Rep
2,030
Posts

Drives: F80, F36, E90
Join Date: Aug 2011
Location: Bay Area

iTrader: (3)

Quote:
Originally Posted by Almaretto View Post
Negative.
so need to do it old school way?
Appreciate 0
      09-21-2019, 12:51 AM   #1498
Almaretto
Major General
Almaretto's Avatar
United_States
1885
Rep
7,785
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by itrocks4u View Post
so need to do it old school way?
Yes. You have to do it the easy way with E-sys.
Appreciate 0
      10-12-2019, 07:53 AM   #1499
adc
Major General
United_States
1365
Rep
5,710
Posts

Drives: 2015 F80 M3 ED
Join Date: Sep 2006
Location: MD/DC

iTrader: (6)

Quote:
Originally Posted by Almaretto View Post
Yes. You have to do it the easy way with E-sys.
Paging Almaretto, your inbox is full and I need your help with remote coding.
__________________

2018 F80 Santorini
2004 Z4 3.0
2014 X3 35i
Appreciate 0
      10-12-2019, 06:40 PM   #1500
Almaretto
Major General
Almaretto's Avatar
United_States
1885
Rep
7,785
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by adc View Post
Paging Almaretto, your inbox is full and I need your help with remote coding.
Deleted 50 messages. You can resend.
Appreciate 0
      10-17-2019, 09:34 PM   #1501
roozybeh
Enlisted Member
35
Rep
48
Posts

Drives: F48 BMW X1 x-drive
Join Date: Apr 2016
Location: Philadelphia, US

iTrader: (0)

Question for X3

So I just got my 2020 x3 m package delivered today

I pretty much loaded it with everything. I do see the “decode dazzle” bs as a line item. The car does have the LED adaptive lighting system with all the other options.

Can someone help me and tell me if I can code the E.U. setting for the LED lights? And if yes, can that someone help me to code it?

I find it annoying that I ordered all the options including the adaptive LED specifically to get the no-dazzle option, and then come to find out that it’s disabled because of an ancient law!

Anyways, any help will be appreciated and rightfully compensated. Thanks in advance.
Appreciate 0
      10-17-2019, 09:41 PM   #1502
Almaretto
Major General
Almaretto's Avatar
United_States
1885
Rep
7,785
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by roozybeh View Post
So I just got my 2020 x3 m package delivered today
F97 or G01?
Appreciate 0
      10-18-2019, 03:32 AM   #1503
roozybeh
Enlisted Member
35
Rep
48
Posts

Drives: F48 BMW X1 x-drive
Join Date: Apr 2016
Location: Philadelphia, US

iTrader: (0)

Quote:
Originally Posted by Almaretto View Post
F97 or G01?
G01
Appreciate 0
      10-19-2019, 12:52 AM   #1504
Almaretto
Major General
Almaretto's Avatar
United_States
1885
Rep
7,785
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by roozybeh View Post
G01
Can easily be coded. Do it all the time.
Appreciate 0
      10-19-2019, 07:42 AM   #1505
roozybeh
Enlisted Member
35
Rep
48
Posts

Drives: F48 BMW X1 x-drive
Join Date: Apr 2016
Location: Philadelphia, US

iTrader: (0)

Quote:
Originally Posted by Almaretto View Post
Can easily be coded. Do it all the time.
Just DM you.
Appreciate 0
      10-29-2019, 02:47 PM   #1506
psyki
E36fiend
United_States
88
Rep
250
Posts

Drives: 2014 435i xDrive
Join Date: May 2019
Location: Sammamish, WA

iTrader: (1)

Garage List
2014 435i xDrive  [0.00]
2014 X5  [0.00]
Follow-up question here, what are the coding parameters that change the speed at which the adaptive high beams are enabled?
Appreciate 0
      10-29-2019, 07:58 PM   #1507
pmooiweer
Zymurgist
United_States
74
Rep
151
Posts

Drives: 2018 BMW M3 (F80)
Join Date: May 2012
Location: Philadelphia area

iTrader: (0)

Quote:
Originally Posted by psyki View Post
Follow-up question here, what are the coding parameters that change the speed at which the adaptive high beams are enabled?
See https://www.bimmerpost.com/forums/sh...php?p=22437451 and the posts right before that one.
Appreciate 0
      11-05-2019, 10:18 PM   #1508
p.o.t.u.s
Private
10
Rep
66
Posts

Drives: 2020 X7 40i
Join Date: Oct 2014
Location: USA

iTrader: (0)

Quote:
Originally Posted by Almaretto View Post
Can easily be coded. Do it all the time.

Can you code a G07?
Appreciate 0
      11-05-2019, 10:27 PM   #1509
Almaretto
Major General
Almaretto's Avatar
United_States
1885
Rep
7,785
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by p.o.t.u.s View Post
Can you code a G07?
In general, yes. For NGHB, still testing.
Appreciate 0
      11-06-2019, 10:05 AM   #1510
p.o.t.u.s
Private
10
Rep
66
Posts

Drives: 2020 X7 40i
Join Date: Oct 2014
Location: USA

iTrader: (0)

Quote:
Originally Posted by Almaretto View Post
In general, yes. For NGHB, still testing.

Awesome. How is progress going on the full euro LED functionality?
Appreciate 0
      11-07-2019, 12:49 AM   #1511
Almaretto
Major General
Almaretto's Avatar
United_States
1885
Rep
7,785
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by p.o.t.u.s View Post
Awesome. How is progress going on the full euro LED functionality?
I am getting close to working formula. I need a few more weeks of testing.
Appreciate 0
      11-07-2019, 01:55 PM   #1512
2kaccordocoupe
Brigadier General
2kaccordocoupe's Avatar
Canada
604
Rep
4,032
Posts

Drives: MY2020 X4MC
Join Date: Nov 2008
Location: The Six

iTrader: (2)

Almaretto
Would you happen have the instructions to enable this on an F98? Thanks!

I-Step: S15A-19-07-553
Appreciate 0
      11-13-2019, 02:09 AM   #1513
Almaretto
Major General
Almaretto's Avatar
United_States
1885
Rep
7,785
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by 2kaccordocoupe View Post
Almaretto
Would you happen have the instructions to enable this on an F98? Thanks!

I-Step: S15A-19-07-553
It is the same coding as a G01, but I do not have instructions on how to do it.
Appreciate 0
      11-13-2019, 10:16 PM   #1514
F83-6MT
Registered
0
Rep
1
Posts

Drives: BMW F83
Join Date: Nov 2019
Location: Philadelphia Burbs, PA

iTrader: (0)

Hello. Way late to this thread but does anyone have an updated recommendation on where to get the updated switch for the F83? I only saw one and it was north of $150 and I thought a lot of people paid far less.
Appreciate 0
      11-14-2019, 08:24 PM   #1515
2kaccordocoupe
Brigadier General
2kaccordocoupe's Avatar
Canada
604
Rep
4,032
Posts

Drives: MY2020 X4MC
Join Date: Nov 2008
Location: The Six

iTrader: (2)

Quote:
Originally Posted by Almaretto View Post
Quote:
Originally Posted by 2kaccordocoupe View Post
Almaretto
Would you happen have the instructions to enable this on an F98? Thanks!

I-Step: S15A-19-07-553
It is the same coding as a G01, but I do not have instructions on how to do it.
Thanks!
Appreciate 0
      11-15-2019, 10:29 PM   #1516
HyeM3
New Member
HyeM3's Avatar
United_States
2
Rep
20
Posts

Drives: BMW M3
Join Date: Sep 2019
Location: California

iTrader: (1)

I have a question that I was wondering if anyone can help me out with.

In step 3 of the PDF it wasn't showing an "Unknown" option for me under LUT_HBA_CODRV_VERT to select so I just left it as it was and changed the Werte values myself. The PDF says to you select any value and after you change the Werte it would revert to "Unknown". But for me after I changed the Werte it stayed the same and didnt revert to "Unknown". Should I change the VO value to something else or is it fine since I have the correct Werte value?

Thanks in advance!

Last edited by HyeM3; 11-15-2019 at 10:57 PM..
Appreciate 0
      11-16-2019, 02:06 AM   #1517
Almaretto
Major General
Almaretto's Avatar
United_States
1885
Rep
7,785
Posts

Drives: Test Vehicles
Join Date: Dec 2015
Location: Mountain View, CA

iTrader: (0)

Quote:
Originally Posted by HyeM3 View Post
I have a question that I was wondering if anyone can help me out with.

In step 3 of the PDF it wasn't showing an "Unknown" option for me under LUT_HBA_CODRV_VERT to select so I just left it as it was and changed the Werte values myself. The PDF says to you select any value and after you change the Werte it would revert to "Unknown". But for me after I changed the Werte it stayed the same and didnt revert to "Unknown". Should I change the VO value to something else or is it fine since I have the correct Werte value?

Thanks in advance!
Car does not care about drop-down menu. You change one or the other; however, ultimately, all that matters are werte values.

If there is no corresponding option for configured value, then it displays as "Unknown."
Appreciate 0
      11-16-2019, 08:32 PM   #1518
HyeM3
New Member
HyeM3's Avatar
United_States
2
Rep
20
Posts

Drives: BMW M3
Join Date: Sep 2019
Location: California

iTrader: (1)

Quote:
Originally Posted by Almaretto View Post
Car does not care about drop-down menu. You change one or the other; however, ultimately, all that matters are werte values.

If there is no corresponding option for configured value, then it displays as "Unknown."
Yeah I figured as long as the Were value was correct it should be good. Just thought it was weird that the drop down value didn't automatically change to unknown. Thanks for the help!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:58 PM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST