European Auto Source (EAS)
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics

Post Reply
 
Thread Tools Search this Thread
      06-10-2019, 08:45 PM   #1
millerrh
New Member
0
Rep
19
Posts

Drives: 2018 BMW M3
Join Date: May 2019
Location: Austin TX

iTrader: (0)

Erratic Bluetooth Connection

I've had my 2018 M3 for a little over a month now and listen to my iPhone XS Max (iOS 12.3.1) over Bluetooth frequently. Mostly it has been issue free, but occasionally, it's like it struggles to get connection to my phone.

What will happen is music will start playing as if it connects, but the screen just says "Please Wait..." instead of showing the track list and I can't use any controls....just plays the first song in my playlist. If I wait long enough, it will often then disconnect from my phone and say it can't connect to it.

Other times, I wait long enough, the tracks will show up and I can scroll through them, but the album artwork doesn't show and seems to act very sluggish.

So no idea what could be going on here with this intermittent issue. Anyone got any tips? I just updated the software through the BMW Software Update site and it doesn't appear this issue was part of the fixes.
Appreciate 0
      06-11-2019, 09:40 PM   #2
millerrh
New Member
0
Rep
19
Posts

Drives: 2018 BMW M3
Join Date: May 2019
Location: Austin TX

iTrader: (0)

Tried unpairing both phone and car from each other and re-pairing. No fix.

But turning my phone off and then on again seemed to have fixed this for me. Will see if this issue comes back if turning off and on again works again or was just a coincidence this time.
Appreciate 0
      06-11-2019, 10:40 PM   #3
icebiker
Enlisted Member
26
Rep
37
Posts

Drives: 2016 F83 6MT
Join Date: Feb 2019
Location: New Jersey

iTrader: (0)

I play pandora via my iPhone on my 2016 M. I find a similar issue. The phone will connect to Bluetooth for phone calls fine but with pandora it often will show the track on the car's screen and will show the progress bar indicating the music is playing but no sound comes out of the speakers even if I turn the volume dial. The only cure I've found is to swipe pandora closed and re-open it.
Appreciate 0
      06-24-2019, 06:12 PM   #4
hellas203
Private
18
Rep
66
Posts

Drives: 1995 e 36 m3
Join Date: Aug 2009
Location: connecticut usa/ volos hellas

iTrader: (0)

Quote:
Originally Posted by icebiker View Post
I play pandora via my iPhone on my 2016 M. I find a similar issue. The phone will connect to Bluetooth for phone calls fine but with pandora it often will show the track on the car's screen and will show the progress bar indicating the music is playing but no sound comes out of the speakers even if I turn the volume dial. The only cure I've found is to swipe pandora closed and re-open it.
Same thing then I put in my usb wire. Don't know wth is wrong but it gets spotty with bt
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:20 PM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST