Autotalent
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Mechanical Maintenance: Break-in | Oil & Fluids | Servicing | TSB | Recalls

Post Reply
 
Thread Tools Search this Thread
      09-19-2015, 06:56 PM   #89
Drizz
Lieutenant
Drizz's Avatar
161
Rep
588
Posts

Drives: '15 YMB F80; '14 MW F15
Join Date: Dec 2011
Location: Orange County, CA

iTrader: (0)

This just happened to me. Totally stock car, never been to a track, drive pretty normal. I took it to get gas, drove slow in traffic to get there. Filled up the tank, started the car and got that error. Stopped and started the car again and no error. I hope nothing bad happens as I've seen others post about needing to flatbed their car.
Appreciate 0
      09-21-2015, 10:24 PM   #90
MaynardZed
Lieutenant Colonel
MaynardZed's Avatar
United_States
1023
Rep
1,717
Posts

Drives: wife crazy
Join Date: Jul 2014
Location: Phoenix

iTrader: (0)

Garage List
Quote:
Originally Posted by Drizz View Post
This just happened to me. Totally stock car, never been to a track, drive pretty normal. I took it to get gas, drove slow in traffic to get there. Filled up the tank, started the car and got that error. Stopped and started the car again and no error. I hope nothing bad happens as I've seen others post about needing to flatbed their car.
Don't worry, no one has ever needed a flatbed for this issue. It usually goes away if you stop and restart car, annoying yes. Worse case scenario, you could disconnect the EDC cables going into the struts and drive in sport+ suspension setting. You can have it looked at, they might replace the sensor as a first step.

Update on my M4: Left strut, sensor, and cable replaced at recent 10K service. Both struts have now been replaced along with sensors and cables. Car driving fine at moment.
__________________
Road course laptimes for BMW M4 2015 6MT
WHP East Track: 1:04.880, Arizona Motorsports Park: 1:54.352
Road course laptimes for Porsche 911 991.1 GTS 7MT
WHP East Track: 1:02.770, Arizona Motorsports Park: 1:48.889
Appreciate 0
      09-22-2015, 05:26 PM   #91
Status Gruppe MNF
BimmerPost Supporting Vendor
Status Gruppe MNF's Avatar
204
Rep
848
Posts


Drives: 03.5 M3 / 2015 M3 Individual
Join Date: Oct 2014
Location: San Diego

iTrader: (0)

Has anyone's steering wheel turn after this happens? we had the malfunction and now our steering wheel is off
-Status
Appreciate 0
      09-22-2015, 07:43 PM   #92
MaynardZed
Lieutenant Colonel
MaynardZed's Avatar
United_States
1023
Rep
1,717
Posts

Drives: wife crazy
Join Date: Jul 2014
Location: Phoenix

iTrader: (0)

Garage List
Quote:
Originally Posted by Status Gruppe MNF View Post
Has anyone's steering wheel turn after this happens? we had the malfunction and now our steering wheel is off
-Status
No steering wheel issues here. I'd guess your issue would not trace back to the struts or EDC system, but maybe to a steering angle sensor (also shows up as a chassis malfunction)?

IIRC when I was doing my initial research on my problem, I came across some issues with steering angle sensors in the E9X causing "chassis malfunctions".
__________________
Road course laptimes for BMW M4 2015 6MT
WHP East Track: 1:04.880, Arizona Motorsports Park: 1:54.352
Road course laptimes for Porsche 911 991.1 GTS 7MT
WHP East Track: 1:02.770, Arizona Motorsports Park: 1:48.889
Appreciate 0
      11-12-2015, 05:45 PM   #93
MaynardZed
Lieutenant Colonel
MaynardZed's Avatar
United_States
1023
Rep
1,717
Posts

Drives: wife crazy
Join Date: Jul 2014
Location: Phoenix

iTrader: (0)

Garage List
Quote:
Originally Posted by MaynardZed View Post
Update:

My car has thrown the "Chassis Malfunction" code at least 3-4 times lately while just driving normally on the street and a couple of times when its just sitting there idling getting it out of storage. Annoying.

It will be going in again soon for 10,000 mile service.
Haven't updated in awhile, but at the 10,000 mile service they noticed the new codes and decided to replace the other strut and sensor also. So now both front struts and sensors have been replaced and the car has been running fine since.

Took it to drift school and a track day at Willow Springs with no error codes.
__________________
Road course laptimes for BMW M4 2015 6MT
WHP East Track: 1:04.880, Arizona Motorsports Park: 1:54.352
Road course laptimes for Porsche 911 991.1 GTS 7MT
WHP East Track: 1:02.770, Arizona Motorsports Park: 1:48.889

Last edited by MaynardZed; 11-18-2015 at 08:03 AM..
Appreciate 2
amw896480.50

      11-15-2015, 02:13 PM   #94
tonymac1
Captain
tonymac1's Avatar
United_States
176
Rep
673
Posts

Drives: 2019 X3 M40i
Join Date: Dec 2010
Location: Chicago

iTrader: (1)

my car just had the same code showing up.... went for a grocery run and the code showed up, stock tune, 265/305 tire set up , mpe with downpipes.
__________________
2019 X3 M40i-Dark Graphite/Cognac
Appreciate 0
      11-18-2015, 07:55 AM   #95
MaynardZed
Lieutenant Colonel
MaynardZed's Avatar
United_States
1023
Rep
1,717
Posts

Drives: wife crazy
Join Date: Jul 2014
Location: Phoenix

iTrader: (0)

Garage List
OK, so I spoke too soon. Chassis Malfunction code showed up again at Arizona Motorsports Park, third session of the day last Saturday. The good news is that my EDC cable disconnect plan worked just fine. I completed 2 more full sessions with them disconnected and my lap times were consistent.

The M4 is in a sorry state after this most recent track day ("chassis malfunction" warning, wheel shimmy, screaching from rotor shield, clunking from left front strut mount area). I won't have time to take at a good look at for a few weeks, so I just threw it in storage for now. Likely most issues are just normal track day debris / schlag.

All that being said, overall the car performed great on the track!
__________________
Road course laptimes for BMW M4 2015 6MT
WHP East Track: 1:04.880, Arizona Motorsports Park: 1:54.352
Road course laptimes for Porsche 911 991.1 GTS 7MT
WHP East Track: 1:02.770, Arizona Motorsports Park: 1:48.889
Appreciate 0
      11-18-2015, 10:57 AM   #96
chillindrdude
Lieutenant Colonel
chillindrdude's Avatar
1005
Rep
1,699
Posts

Drives: anything with 4 wheels
Join Date: Feb 2015
Location: Virginia

iTrader: (1)

Quote:
Originally Posted by MaynardZed View Post
OK, so I spoke too soon. Chassis Malfunction code showed up again at Arizona Motorsports Park, third session of the day last Saturday. The good news is that my EDC cable disconnect plan worked just fine. I completed 2 more full sessions with them disconnected and my lap times were consistent.

The M4 is in a sorry state after this most recent track day ("chassis malfunction" warning, wheel shimmy, screaching from rotor shield, clunking from left front strut mount area). I won't have time to take at a good look at for a few weeks, so I just threw it in storage for now. Likely most issues are just normal track day debris / schlag.

All that being said, overall the car performed great on the track!
that clunking...was it only apparent on a hard turn?

my M3 at the last track session (the differential lock error came on), the instructor said he heard a clunking sound with hard left turns, like when the car loaded up on the suspension in the corner. he thought maybe it was a loose endlink or something.

honestly, it wasn't something that was super apparent to me as the driver, perhaps because i was pretty focused on driving during those times.

i mentioned it to my SA when i brought it in for the differential lock error. since i picked up the car, i haven't heard anything. granted, i don't corner as hard just street driving, but i hope it doesn't recur.
__________________
My Trackable Street Car
2016 Porsche GT4 -- 981
Appreciate 0
      11-18-2015, 12:03 PM   #97
MaynardZed
Lieutenant Colonel
MaynardZed's Avatar
United_States
1023
Rep
1,717
Posts

Drives: wife crazy
Join Date: Jul 2014
Location: Phoenix

iTrader: (0)

Garage List
Didn't hear the strut clunking until the morning after when it was cold, then it went away by the time I got to my storage unit. It was definitely coming from the front somewhere, not the diff.
__________________
Road course laptimes for BMW M4 2015 6MT
WHP East Track: 1:04.880, Arizona Motorsports Park: 1:54.352
Road course laptimes for Porsche 911 991.1 GTS 7MT
WHP East Track: 1:02.770, Arizona Motorsports Park: 1:48.889
Appreciate 0
      11-18-2015, 01:08 PM   #98
W///
Lieutenant General
W///'s Avatar
4117
Rep
10,800
Posts

Drives: 08 E92 M3 /07 Z4MR / 99 E36 M3
Join Date: Sep 2011
Location: SC

iTrader: (13)

I can't believe you've been dealing with this for close to a year and it's still not gone away. I'm surprised you aren't more upset than you are. This makes me really consider going with passive instead (also looking to potentially keep the car past 100k miles).
__________________
Current: E92 M3 Sparkling Graphite/Bamboo Beige/6MT. E36 M3 Techno Violet/Dove/5MT. E85 Z4MR Alpine White/Imola Red/6MT
Appreciate 1
      11-19-2015, 07:51 AM   #99
MaynardZed
Lieutenant Colonel
MaynardZed's Avatar
United_States
1023
Rep
1,717
Posts

Drives: wife crazy
Join Date: Jul 2014
Location: Phoenix

iTrader: (0)

Garage List
Quote:
Originally Posted by W/// View Post
I can't believe you've been dealing with this for close to a year and it's still not gone away. I'm surprised you aren't more upset than you are. This makes me really consider going with passive instead (also looking to potentially keep the car past 100k miles).
Thanks, I guess I consider it more of an electrical gremlin and annoyance than anything mechanical. Even though both front struts have been replaced I don't think there has ever been anything wrong with my car mechanically. The car does perform flawlessly otherwise and now that I've figured out a work around I know what to do for track days.

I would definitely order the passive suspension if I was doing it over again.
__________________
Road course laptimes for BMW M4 2015 6MT
WHP East Track: 1:04.880, Arizona Motorsports Park: 1:54.352
Road course laptimes for Porsche 911 991.1 GTS 7MT
WHP East Track: 1:02.770, Arizona Motorsports Park: 1:48.889
Appreciate 0
      01-25-2016, 05:46 PM   #100
W///
Lieutenant General
W///'s Avatar
4117
Rep
10,800
Posts

Drives: 08 E92 M3 /07 Z4MR / 99 E36 M3
Join Date: Sep 2011
Location: SC

iTrader: (13)

Quote:
Originally Posted by MaynardZed View Post
Thanks, I guess I consider it more of an electrical gremlin and annoyance than anything mechanical. Even though both front struts have been replaced I don't think there has ever been anything wrong with my car mechanically. The car does perform flawlessly otherwise and now that I've figured out a work around I know what to do for track days.

I would definitely order the passive suspension if I was doing it over again.
Did you get this issue again? Now that ZCP has been released, do you still think you'd go with passive if you had to do it again?
Appreciate 0
      01-28-2016, 09:57 PM   #101
Stryatch
Second Lieutenant
9
Rep
248
Posts

Drives: '15 F80 MW/SO
Join Date: Sep 2010
Location: California

iTrader: (0)

I too just went to get gas and drove away super normal and it gave me "Chassis function restricted" error. But it's not going away.
__________________
2015 F80 MW/SO DCT current
2013 F10 M5 SG/B 6 spd sold
2008 E90 M3 AW/B 6 spd sold
Appreciate 0
      01-29-2016, 05:39 AM   #102
MaynardZed
Lieutenant Colonel
MaynardZed's Avatar
United_States
1023
Rep
1,717
Posts

Drives: wife crazy
Join Date: Jul 2014
Location: Phoenix

iTrader: (0)

Garage List
Quote:
Originally Posted by W/// View Post
Did you get this issue again? Now that ZCP has been released, do you still think you'd go with passive if you had to do it again?
Haven't gotten it in awhile, but haven't been driving the M4 much. Yes, I would still stay away from M adaptive if I was ordering again. I like simple, less likely to break.
__________________
Road course laptimes for BMW M4 2015 6MT
WHP East Track: 1:04.880, Arizona Motorsports Park: 1:54.352
Road course laptimes for Porsche 911 991.1 GTS 7MT
WHP East Track: 1:02.770, Arizona Motorsports Park: 1:48.889
Appreciate 1
      01-29-2016, 06:47 AM   #103
W///
Lieutenant General
W///'s Avatar
4117
Rep
10,800
Posts

Drives: 08 E92 M3 /07 Z4MR / 99 E36 M3
Join Date: Sep 2011
Location: SC

iTrader: (13)

Quote:
Originally Posted by MaynardZed View Post
Haven't gotten it in awhile, but haven't been driving the M4 much. Yes, I would still stay away from M adaptive if I was ordering again. I like simple, less likely to break.
Yup, unless the ZCP is THAT much better to drive (I doubt it will be), I think I'm just going to go with an Individual F80 with literally just LED as extra. The more I think about it, the more I love the idea of a no nonsense build like that.

Thanks for the advice!
__________________
Current: E92 M3 Sparkling Graphite/Bamboo Beige/6MT. E36 M3 Techno Violet/Dove/5MT. E85 Z4MR Alpine White/Imola Red/6MT
Appreciate 0
      01-29-2016, 08:17 AM   #104
shortseller
Brigadier General
shortseller's Avatar
United_States
884
Rep
3,297
Posts

Drives: 2018 M3 ZCP
Join Date: Aug 2010
Location: NOVA

iTrader: (0)

OP, this has been a fascinating read as well as informative. Glad to see you've gotten to a workaround to get to enjoy the car as it was meant to be. You are probably one of the few that really take their cars closer to the limits than most, wish I could say that of myself but I can live vicariously.

As to the M3/4; a MT with passive suspension, IMO keeps this car as close to its roots as possible, fun, simple and predictable,...during these times of public cravings for hi-tech electric self drive & self parking cars, an era of good or bad that we find ourselves in, we are being robbed of driving the "ultimate" experience.
__________________

Last edited by shortseller; 01-29-2016 at 09:03 AM..
Appreciate 2
      01-29-2016, 10:20 AM   #105
W///
Lieutenant General
W///'s Avatar
4117
Rep
10,800
Posts

Drives: 08 E92 M3 /07 Z4MR / 99 E36 M3
Join Date: Sep 2011
Location: SC

iTrader: (13)

Quote:
Originally Posted by shortseller View Post
OP, this has been a fascinating read as well as informative. Glad to see you've gotten to a workaround to get to enjoy the car as it was meant to be. You are probably one of the few that really take their cars closer to the limits than most, wish I could say that of myself but I can live vicariously.

As to the M3/4; a MT with passive suspension, IMO keeps this car as close to its roots as possible, fun, simple and predictable,...during these times of public cravings for hi-tech electric self drive & self parking cars, an era of good or bad that we find ourselves in, we are being robbed of driving the "ultimate" experience.
Couldn't agree with you more. I'll have other cars that can will be more comfortable than an M3 with adaptive shocks anyway, so I'd rather just get something that as you say, is the essence of the Ultimate Driving Machine.

Thank you both for saving me $5500 and skipping ZCP. Signal Green stripper it is
__________________
Current: E92 M3 Sparkling Graphite/Bamboo Beige/6MT. E36 M3 Techno Violet/Dove/5MT. E85 Z4MR Alpine White/Imola Red/6MT
Appreciate 4
      03-30-2016, 09:59 AM   #106
DavidGP
Lieutenant
305
Rep
443
Posts

Drives: 2016 MG F80 6spd
Join Date: Aug 2015
Location: USA

iTrader: (0)

I was turning into the business park where I work and I got the "Chassis function restricted" message. Took it to BMW and they told me they are replacing a shock and its coming from Germany and it will take two weeks. I wonder if there is an updated shock they are replacing it with.
Appreciate 0
      04-12-2016, 06:55 PM   #107
Hoosierlegend
Private
8
Rep
54
Posts

Drives: M3
Join Date: Aug 2015
Location: USA

iTrader: (0)

Same problem today. Happened after just starting car and starting driving in parking lot. Error message went away after turning off car and turning back on. Car is stock, adaptive suspension.

Car never driven aggressively in turning. Don't drive on track and roads here pretty straight.
Appreciate 0
      07-01-2016, 09:39 PM   #108
mattkim85
Second Lieutenant
mattkim85's Avatar
United_States
34
Rep
268
Posts

Drives: 2018 MW F83
Join Date: Apr 2011
Location: Los Angeles

iTrader: (2)

Any updates on a fix?

I was parking my car in my driveway yesterday (spot has a slight incline) and I suddenly got a chassis malfunction message. I was at full clockwise lock pulling in.

I started up the car this morning (fingers crossed) and the chassis malfunction warning pops up again. It is for sure in Sport +, and I can still change steering and throttle response. I can also change traction control too.

I'm just worried about taking the car to a dealer since I recently got the Hex Tune Flash and I'm lowered on H&R Sports.

Any help would be greatly appreciated.
__________________
2010 E93 M3 JB
2013 F10 M5 SG
2015 F82 M4 BSM
2018 F83 M4 MW
Appreciate 0
      10-01-2016, 12:26 PM   #109
adc
Major General
United_States
1301
Rep
5,668
Posts

Drives: 2015 F80 M3 ED
Join Date: Sep 2006
Location: MD/DC

iTrader: (6)

Got it today twice going into Carousel at Shenandoah. Trying one more session just for kicks, but it's going to bmw Monday morning.
Appreciate 1
///Mongo259.00

      10-01-2016, 10:09 PM   #110
larryn
Lieutenant General
United_States
2009
Rep
10,169
Posts

Drives: '97 332ti, '18 F31, '16 GT4
Join Date: May 2005
Location: Seattle

iTrader: (2)

Quote:
Originally Posted by adc View Post
Got it today twice going into Carousel at Shenandoah. Trying one more session just for kicks, but it's going to bmw Monday morning.
How did the pads work out? Did you need to replace them? I got through today on my RS29s, with probably two more days left on them.

Apologies for the OT.. We now resume regularly scheduled programming.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:55 PM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST