GetBMWParts
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Engine / Drivetrain / Exhaust / Bolt-ons / Tuning

Post Reply
 
Thread Tools Search this Thread
      02-16-2015, 12:43 PM   #1
Ridicule23
Private First Class
36
Rep
164
Posts

Drives: F80 M3
Join Date: May 2013
Location: Brookville,NY

iTrader: (0)

JB4 Frustration (hiccups)

hello all, I'm sure this is a common issue going on. I've had my jb4 for about 4 months now. currently at map 2 with Downpipes and filter... after some hard driving I would get some hiccups and choking of the fuel whenever I'm at a full stop. it's not the whole time, but it's very common. when I first got the jb4 and started with map 0, this wasn't an issue, but ever since I enabled the wastegate control I've been getting these issues. however I would also get a driver malfunction at times, but would go away and not got into limp mode. I ended up taking my car to the dealer, and they said I would have to remove the jb4 in order for them to do complete testing. as much as I love this jb4, I would hate to have to disable it completely and revert back to stock in order for me to not have this issue. in addition I'm even up to date with the firmware, as others have claimed to fix this so called issue. I'm open to hear what others have to say about this issue, and if there is a FIX for it. because I am very unhappy with this situation because it's embarrassing when my car feels like it's about to shut down.
Appreciate 1
      02-16-2015, 12:48 PM   #2
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
3691
Rep
94,341
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

Quote:
Originally Posted by Ridicule23 View Post
hello all, I'm sure this is a common issue going on. I've had my jb4 for about 4 months now. currently at map 2 with Downpipes and filter... after some hard driving I would get some hiccups and choking of the fuel whenever I'm at a full stop. it's not the whole time, but it's very common. when I first got the jb4 and started with map 0, this wasn't an issue, but ever since I enabled the wastegate control I've been getting these issues. however I would also get a driver malfunction at times, but would go away and not got into limp mode. I ended up taking my car to the dealer, and they said I would have to remove the jb4 in order for them to do complete testing. as much as I love this jb4, I would hate to have to disable it completely and revert back to stock in order for me to not have this issue. in addition I'm even up to date with the firmware, as others have claimed to fix this so called issue. I'm open to hear what others have to say about this issue, and if there is a FIX for it. because I am very unhappy with this situation because it's embarrassing when my car feels like it's about to shut down.
Why would you post here instead of on BMS' forum where they could help you resolve it? Send a log of the issue and the exact codes over to BMS so they can help you sort it out.

Mike
__________________
Appreciate 1
      02-16-2015, 12:50 PM   #3
brianeck
Part Time Firetruck Crash Barrier
brianeck's Avatar
645
Rep
1,431
Posts

Drives: 2015 F80 M3 Sakhir/Amaro Brown
Join Date: Mar 2013
Location: Nyack NY

iTrader: (0)

My first guess would be bad or inadequate gas. Do you always fill up at the same place? I used to have an issue filling up at a particular station nearby that claims 93 octane, but obviously something was up because I would "knock" a little bit with my jb4 map 2 on my 335. . .
__________________
2015 m3 6mt Sakhir Orange/Amaro Brown Geri Halliwell (Ginger)

**RETIRED
Currently on the darkside with an APR stage 2.5 B8 S4 and not really regretting that much. I'll be back one day.
Appreciate 0
      02-16-2015, 01:07 PM   #4
Ridicule23
Private First Class
36
Rep
164
Posts

Drives: F80 M3
Join Date: May 2013
Location: Brookville,NY

iTrader: (0)

Quote:
Originally Posted by Mike@N54Tuning.com
Quote:
Originally Posted by Ridicule23 View Post
hello all, I'm sure this is a common issue going on. I've had my jb4 for about 4 months now. currently at map 2 with Downpipes and filter... after some hard driving I would get some hiccups and choking of the fuel whenever I'm at a full stop. it's not the whole time, but it's very common. when I first got the jb4 and started with map 0, this wasn't an issue, but ever since I enabled the wastegate control I've been getting these issues. however I would also get a driver malfunction at times, but would go away and not got into limp mode. I ended up taking my car to the dealer, and they said I would have to remove the jb4 in order for them to do complete testing. as much as I love this jb4, I would hate to have to disable it completely and revert back to stock in order for me to not have this issue. in addition I'm even up to date with the firmware, as others have claimed to fix this so called issue. I'm open to hear what others have to say about this issue, and if there is a FIX for it. because I am very unhappy with this situation because it's embarrassing when my car feels like it's about to shut down.
Why would you post here instead of on BMS' forum where they could help you resolve it? Send a log of the issue and the exact codes over to BMS so they can help you sort it out.

Mike
sorry about that mike, just figured how active this forum is I'd get a quicker response. I have a p3 gauge, that shows some codes, will that tell me ? or do I have to run a data log with a usb, because I don't have 1.
Appreciate 0
      02-16-2015, 01:15 PM   #5
NorCal f80
Lieutenant Colonel
319
Rep
1,664
Posts

Drives: M3
Join Date: Apr 2014
Location: Nor Cal

iTrader: (0)

Trying to ridicule JB.
Appreciate 1
      02-16-2015, 01:20 PM   #6
teamwerx
Private First Class
teamwerx's Avatar
30
Rep
179
Posts

Drives: 2015 M4
Join Date: Nov 2014
Location: Badassville

iTrader: (0)

The BMS stuff seems like the go to, but that's two issues in one day on the forum..
Appreciate 0
      02-16-2015, 01:23 PM   #7
///M ARMY
Colonel
661
Rep
2,757
Posts

Drives: F90
Join Date: Jul 2012
Location: Cali

iTrader: (2)

Garage List
2019 BMW M5  [0.00]
2017 Ford Raptor  [0.00]
2016 Charger SRT 392  [0.00]
2015 M3  [0.00]
Quote:
Originally Posted by Mike@N54Tuning.com View Post
Why would you post here instead of on BMS' forum where they could help you resolve it? Send a log of the issue and the exact codes over to BMS so they can help you sort it out.

Mike
Very true. It also sound like a fuel issue. Not the proper mix. Personally I have always did 5 gallons of E85 then top of with 91
__________________
2017 Ford Raptor
2019 BMW M5-Nardo Grey
Appreciate 0
      02-16-2015, 01:34 PM   #8
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
3691
Rep
94,341
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

Quote:
Originally Posted by teamwerx View Post
The BMS stuff seems like the go to, but that's two issues in one day on the forum..
It's always been like that because the BMS stuff is 5x more popular than anything else. So you get more requests for support and problem solving. The issue is when they post here there is no one to help them. Just me to tell them to contact BMS. If they post on BMS' support forum then there is an employee trained in this stuff full time reading and answering posts for help. Not to mention their email tech support when you need help quickly.

Mike

Last edited by Mike@N54Tuning.com; 02-16-2015 at 01:43 PM..
Appreciate 0
      02-16-2015, 01:39 PM   #9
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
3691
Rep
94,341
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

Quote:
Originally Posted by Ridicule23 View Post
sorry about that mike, just figured how active this forum is I'd get a quicker response. I have a p3 gauge, that shows some codes, will that tell me ? or do I have to run a data log with a usb, because I don't have 1.
Interesting. You know the P3 w/ CANbus has the potential to interfere with the JB4 CANbus right? It's ill advised to run both together!

I'd say unplug the P3 as a first test. Then if the problem is still there get a BMS USB cable so you can log the issue. The JB4 will display afr bank 1 & 2, timing, throttle, fuel pressure, trims, and from that BMS can determine what is causing that stumble and how to fix it. If you don't have a BMS cable how did you update the firmware?

Mike
__________________
Appreciate 0
      02-16-2015, 02:18 PM   #10
Ridicule23
Private First Class
36
Rep
164
Posts

Drives: F80 M3
Join Date: May 2013
Location: Brookville,NY

iTrader: (0)

Quote:
Originally Posted by Mike@N54Tuning.com
Quote:
Originally Posted by Ridicule23 View Post
sorry about that mike, just figured how active this forum is I'd get a quicker response. I have a p3 gauge, that shows some codes, will that tell me ? or do I have to run a data log with a usb, because I don't have 1.
Interesting. You know the P3 w/ CANbus has the potential to interfere with the JB4 CANbus right? It's ill advised to run both together!

I'd say unplug the P3 as a first test. Then if the problem is still there get a BMS USB cable so you can log the issue. The JB4 will display afr bank 1 & 2, timing, throttle, fuel pressure, trims, and from that BMS can determine what is causing that stumble and how to fix it. If you don't have a BMS cable how did you update the firmware?

Mike
I went to ACM and they updated the firmware.
Appreciate 0
      02-16-2015, 03:07 PM   #11
F80M4ROCKS
Private First Class
F80M4ROCKS's Avatar
29
Rep
109
Posts

Drives: M4
Join Date: Jan 2015
Location: MARYLAND

iTrader: (0)

where is the link to bms support forum?
Appreciate 0
      02-16-2015, 03:36 PM   #12
VCP
Colonel
VCP's Avatar
Canada
1195
Rep
2,227
Posts

Drives: M4GTS BSM/F90comp/F87lci
Join Date: Mar 2011
Location: Canada

iTrader: (0)

Active 8 module with Zima DP's. Perfect! Much smoother power delivery than stock trim. http://5252motorsports.blogspot.ca/2...s-for-bmw.html


Quote:
Originally Posted by Ridicule23 View Post
hello all, I'm sure this is a common issue going on. I've had my jb4 for about 4 months now. currently at map 2 with Downpipes and filter... after some hard driving I would get some hiccups and choking of the fuel whenever I'm at a full stop. it's not the whole time, but it's very common. when I first got the jb4 and started with map 0, this wasn't an issue, but ever since I enabled the wastegate control I've been getting these issues. however I would also get a driver malfunction at times, but would go away and not got into limp mode. I ended up taking my car to the dealer, and they said I would have to remove the jb4 in order for them to do complete testing. as much as I love this jb4, I would hate to have to disable it completely and revert back to stock in order for me to not have this issue. in addition I'm even up to date with the firmware, as others have claimed to fix this so called issue. I'm open to hear what others have to say about this issue, and if there is a FIX for it. because I am very unhappy with this situation because it's embarrassing when my car feels like it's about to shut down.

Last edited by VCP; 03-25-2015 at 01:27 PM..
Appreciate 0
      02-16-2015, 03:57 PM   #13
kitw
Brigadier General
kitw's Avatar
392
Rep
3,000
Posts

Drives: 2013 E93 M3, Jerez Black
Join Date: Jun 2007
Location: Bay Area, CA

iTrader: (20)

Quote:
Originally Posted by Ridicule23 View Post
sorry about that mike, just figured how active this forum is I'd get a quicker response. I have a p3 gauge, that shows some codes, will that tell me ? or do I have to run a data log with a usb, because I don't have 1.
There is almost no one here that knows enough to actually help you troubleshoot the car. Reach out to Terry at BMS, get some datalogs and actually work on solving your problem, rather than grasping at straws.
__________________

DSC_3369 by Kit W, on Flickr
Appreciate 0
      02-16-2015, 05:11 PM   #14
Prestige@ActiveAutowerke
Prestige@ActiveAutowerke's Avatar
11
Rep
60
Posts

Drives: M3
Join Date: Jan 2015
Location: Miami

iTrader: (0)

Quote:
Originally Posted by VCP View Post
Active 8 module with Zima DP's. Perfect! Much smoother power delivery than stock trim. http://5252motorsports.blogspot.ca/2...s-for-bmw.html
Appreciate 1
      02-16-2015, 06:57 PM   #15
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
3691
Rep
94,341
Posts


Drives: 2007 335i, 2015 M3
Join Date: Dec 2008
Location: N54tuning.com

iTrader: (89)

Quote:
Originally Posted by F80M4ROCKS View Post
where is the link to bms support forum?
http://www.n54tech.com/forums/forumdisplay.php?f=35
__________________
Appreciate 0
      02-16-2015, 08:26 PM   #16
8600RPM
Lieutenant Colonel
599
Rep
1,752
Posts

Drives: e92 m3
Join Date: Oct 2014
Location: AZ

iTrader: (0)

Mike you are quick to post on other threads about jb4 yet when people have issues, which I've seen 4 this past 2 weeks on forum, you tell them not to post Here. I think everyone is interested in any problems out there, whether it's is bms or another product
Appreciate 3
      02-16-2015, 08:42 PM   #17
Merli
Sunburnt Member
Australia
144
Rep
505
Posts

Drives: 2015 F82 M4
Join Date: Mar 2007
Location: Sydney, Australia

iTrader: (0)

Quote:
Originally Posted by 8600RPM View Post
Mike you are quick to post on other threads about jb4 yet when people have issues, which I've seen 4 this past 2 weeks on forum, you tell them not to post Here. I think everyone is interested in any problems out there, whether it's is bms or another product
I agree... The bias shown by Mike@N54 is sickening and disingenuous.

He reeks of a used car salesman.... "Don't look at that, look over here at this shiny bit!". Be very careful when telling people not to post, as censorship does NOT sit well with many people.

I for one greatly appreciate M3/M4 owners posting on an M3/M4 board about their issues they're having with their tunes, whether it be JB4 or any other. It adds to our collective knowledge base, and we shouldn't be hiding the issues on some N54 forum. This is a forum to talk about our S55 engines.

I would think that many F8x owners would want to know if a certain tune is too sensitive about fuel quality issues and that not enough safety buffer has been taken into consideration with a certain tuning product. What happens on a hot day, at high altitude, if you happen to get a bad batch of 93?

I know that I have absolutely ZERO interest in a tune that throws the car into limp mode, and is overly sensitive to a batch of fuel that is slightly below the rated octane level, and I am extremely grateful to other F8x owners who share their experiences with all products, whether they be bad or good. But we should hear both sides of the story, and not just the ones that a reseller wants us to hear.
__________________
Road - 2015 Mineral White F82 M4 | Race - Orange Lotus Exige S2

Past: 2009 Ibis White S5 (APR Supercharged V8)
Past: 2004 Imola Red M3 Convertible

Last edited by Merli; 02-16-2015 at 08:56 PM..
Appreciate 1
      02-16-2015, 08:47 PM   #18
Richy Rich
Colonel
Richy Rich's Avatar
United_States
3105
Rep
2,174
Posts

Drives: F80 | MKIV Supra | Aventador S
Join Date: Jan 2014
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by VCP View Post
Active 8 module with Zima DP's. Perfect! Much smoother power delivery than stock trim.
Great idea spamming another tune, but tell me how that competes with my 550whp I'm seeing from a custom map 6 on my JB4?
Appreciate 1
      02-16-2015, 08:55 PM   #19
F80M4ROCKS
Private First Class
F80M4ROCKS's Avatar
29
Rep
109
Posts

Drives: M4
Join Date: Jan 2015
Location: MARYLAND

iTrader: (0)

Quote:
Originally Posted by Mike@N54Tuning.com View Post
thanks mike!
Appreciate 0
      02-16-2015, 09:14 PM   #20
VCP
Colonel
VCP's Avatar
Canada
1195
Rep
2,227
Posts

Drives: M4GTS BSM/F90comp/F87lci
Join Date: Mar 2011
Location: Canada

iTrader: (0)

It can't, and I never claimed it could. Read the OP. I gave my opinion to his question. You are just #1. Does that satisfy your temper tantrum child? By the way, I did have a JB4 previous.


Quote:
Originally Posted by Richy Rich View Post
Great idea spamming another tune, but tell me how that competes with my 550whp I'm seeing from a custom map 6 on my JB4?
Appreciate 0
      02-16-2015, 09:16 PM   #21
Richy Rich
Colonel
Richy Rich's Avatar
United_States
3105
Rep
2,174
Posts

Drives: F80 | MKIV Supra | Aventador S
Join Date: Jan 2014
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by VCP
It can't, and I never claimed it could. Read the OP. I gave my opinion to his question. You are just #1. Does that satisfy your temper tantrum child?


Quote:
Originally Posted by Richy Rich View Post
Great idea spamming another tune, but tell me how that competes with my 550whp I'm seeing from a custom map 6 on my JB4?
No because it wasn't a response seeing his questions were pertaining to map two on the JB4 — instead of offering for him to spend more money maybe you should let those, like above, recommend what may actually be wrong with the vehicle, fuel, and/or product.
Appreciate 0
      02-16-2015, 09:22 PM   #22
teamwerx
Private First Class
teamwerx's Avatar
30
Rep
179
Posts

Drives: 2015 M4
Join Date: Nov 2014
Location: Badassville

iTrader: (0)

Definitely want to hear about problems here instead of n54 tech. I don't want to have to lurk multiple sites to get simple information if I don't have to!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:26 PM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST