BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   BMW M3 and BMW M4 Forum > BMW F80 M3 / F82 M4 Technical Topics > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics

Post Reply
 
Thread Tools Search this Thread
      09-20-2019, 05:30 PM   #1
Racer20
Major
United_States
816
Rep
1,099
Posts

Drives: F80 M3, 228i THP, E46 ZHP
Join Date: May 2009
Location: Ann Arbor, MI

iTrader: (0)

Can't control iPhone music after iOS13 update?

My 2015 doesn't have CarPlay. I can control the music from my phone and hear it through iDrive, but song info doesn't display and none of the music controls in the car work. Same situation for Bluetooth and USB.
__________________
2015 M3, 2005 330i ZHP, 2015 228i 6MT Track Handling Pack, 2007 M Coupe (Sold)
Appreciate 0
      09-21-2019, 02:54 PM   #2
Encanto
Major
Encanto's Avatar
451
Rep
1,198
Posts

Drives: 2018 M3
Join Date: Nov 2015
Location: Florida

iTrader: (1)

Quote:
Originally Posted by Racer20 View Post
My 2015 doesn't have CarPlay. I can control the music from my phone and hear it through iDrive, but song I do doesn't display and none of the music controls in the car work. Same situation for Bluetooth and USB.
Reset, delete, re-pair...
Appreciate 0
      09-21-2019, 09:34 PM   #3
CachacoF80
Lieutenant
United_States
264
Rep
423
Posts

Drives: San Marino Blue F80 - ZCP 6MT
Join Date: Dec 2017
Location: SF Bay Area, CA

iTrader: (0)

I read several articles about many bugs in IOS 13. May want to wait a bit until bugs are fixed?
Appreciate 0
      09-22-2019, 07:44 PM   #4
Encanto
Major
Encanto's Avatar
451
Rep
1,198
Posts

Drives: 2018 M3
Join Date: Nov 2015
Location: Florida

iTrader: (1)

Quote:
Originally Posted by CachacoF80 View Post
I read several articles about many bugs in IOS 13. May want to wait a bit until bugs are fixed?
First update on Tuesday the 24th...
Appreciate 0
      09-23-2019, 09:16 AM   #5
BlownOne
Private
BlownOne's Avatar
26
Rep
79
Posts

Drives: 2018 m4 comp 2016 C63s
Join Date: Aug 2019
Location: Sac, Ca

iTrader: (1)

I’m having trouble with my music connecting and disconnecting or pausing repeatedly as of last week, which could have been after update...
Appreciate 0
      09-25-2019, 08:46 AM   #6
duky
The Tanzanian
duky's Avatar
United_States
644
Rep
1,100
Posts

Drives: BSM F80
Join Date: Jan 2012
Location: Oakland, CA

iTrader: (8)

Garage List
2016 BMW M3  [5.00]
Similar issue though not the same and the issue is with iOS 13.1 in particular because it worked fine on iOS 13. I am not able to select songs from the Now Playing/Up Next list using the iDrive or HUD. When I click a song it just ignores my input. Everything else is normal, I can browse and select songs in playlists, and can also skip one track backward/forward. The issue is just when trying to select a future (upcoming) song
__________________
Current: 2016 F80 Black Sapphire Metallic on Silverstone
Former: 2007 E90 335i Barbera Red on Terra Dakota
Appreciate 0
      09-25-2019, 09:07 PM   #7
Hokayy
New Member
2
Rep
11
Posts

Drives: M3
Join Date: Oct 2014
Location: United States

iTrader: (1)

I have the same issue after updating to iOS 13.1 today. In the morning commute I was still on iOS 13 and everything in iDrive works fine with selecting and changing songs. Once i got to work, I updated to 13.1 and on the commute home, that's when I noticed that iDrive is ignoring my input to select the next song via my steering wheel and using the iDrive knob.

Restarting phone doesn't help either. Start car on and off is the same...however, I did notice that sometimes when I plug in my iPhone via usb the default playlist will always play the first song in my Songs list beginning with "A". If in this playlist, I am able to select songs. But once I go and search for another playlist, I'm only able to select a song to start playing from the list and nothing else afterwards. Cannot select new ones from the playlist.

I also always had a issue where my playlist shows -100,-101,-102...when I scroll down the list. Anyone have this issue too and is there a fix?
Appreciate 0
      09-26-2019, 05:58 AM   #8
Encanto
Major
Encanto's Avatar
451
Rep
1,198
Posts

Drives: 2018 M3
Join Date: Nov 2015
Location: Florida

iTrader: (1)

Try updating the Media firmware via BMW Update...
Appreciate 0
      09-27-2019, 08:36 PM   #9
IK6SPEED
Major General
IK6SPEED's Avatar
United_States
3586
Rep
9,110
Posts

Drives: BMW M3 / AH3
Join Date: Jan 2013
Location: Cali

iTrader: (20)

Quote:
Originally Posted by Encanto View Post
Quote:
Originally Posted by CachacoF80 View Post
I read several articles about many bugs in IOS 13. May want to wait a bit until bugs are fixed?
First update on Tuesday the 24th...
13.1.1 today.

3 versions in a week time.

And it's still buggy.

Steve Jobs is rolling over in his grave.
__________________
Stable: F80 / AH3
Past: F80 ZCP / F22 M235i / E89 35is
Appreciate 1
      10-02-2019, 07:19 AM   #10
OrangeD1sco
Private
7
Rep
62
Posts

Drives: None
Join Date: Aug 2014
Location: None

iTrader: (0)

Quote:
Originally Posted by duky View Post
Similar issue though not the same and the issue is with iOS 13.1 in particular because it worked fine on iOS 13. I am not able to select songs from the Now Playing/Up Next list using the iDrive or HUD. When I click a song it just ignores my input. Everything else is normal, I can browse and select songs in playlists, and can also skip one track backward/forward. The issue is just when trying to select a future (upcoming) song
Having same problem even after last update. Anyone found a fix?
Appreciate 0
      10-02-2019, 08:59 AM   #11
PhatLyfe
First Lieutenant
PhatLyfe's Avatar
78
Rep
334
Posts

Drives: 2015 Toyota Prius
Join Date: Jul 2016
Location: Jersey

iTrader: (0)

just reconnect your phone via bluetooth for carp[lay after new update and worked for me..
Appreciate 0
      10-02-2019, 09:31 PM   #12
pz619
Colonel
1938
Rep
2,467
Posts

Drives: F87 M2C
Join Date: Oct 2013
Location: San Diego

iTrader: (0)

Yes! Same issue here, tried repairing and no change.
Appreciate 0
      10-02-2019, 09:49 PM   #13
Pauldunlop13
Private First Class
104
Rep
138
Posts

Drives: M4 Convertible
Join Date: Sep 2017
Location: Colorado

iTrader: (0)

Quote:
Originally Posted by pz619 View Post
Yes! Same issue here, tried repairing and no change.
Try 13.1.2
__________________
2019 YMB ZCP convertible - Dinan Exhaust (Lease)
2015 M4 Convertible - previous car (writeoff due to battery fire) 2018-2019
2016 228Xi - previous car (was modding it way too much, trade in for the M4) 2017-2018
2003 Acura RSX Type S (until 2017)
Appreciate 0
      10-02-2019, 10:53 PM   #14
pz619
Colonel
1938
Rep
2,467
Posts

Drives: F87 M2C
Join Date: Oct 2013
Location: San Diego

iTrader: (0)

Quote:
Originally Posted by Pauldunlop13 View Post
Try 13.1.2
Actually downloaded and installed it earlier. Same issue unfortunately.
Appreciate 1
      10-03-2019, 02:19 AM   #15
yeg440i
Second Lieutenant
yeg440i's Avatar
Canada
232
Rep
259
Posts

Drives: 2017 440i 6MT with MPPSK
Join Date: Nov 2017
Location: edmonton, alberta

iTrader: (0)

Garage List
2006 BMW 330i  [0.00]
2017 BMW 440i Coupe  [0.00]
2007 BMW 335i  [0.00]
This is not a BMW issue, it is an Apple issue.

Bluetooth / Media problems have plagued other platforms including Audi, Mercedes & Toyota since 13.1. We don't have any real option other than to kick & scream at Apple.

https://discussions.apple.com/thread/250676400?page=1
__________________
2017 440i 6MT Alpine White over Coral Red Leather 2007 335i 6MT Black Sapphire Metallic over Terra Brown Leather
2006 330i 6MT Arctic Metallic over Ivory White Leather (SOLD)
Appreciate 1
RickFLM43888.00

      10-03-2019, 08:38 PM   #16
Nonopr01
Lieutenant
99
Rep
521
Posts

Drives: 2017 BMW M3
Join Date: Aug 2015
Location: San Juan, PR

iTrader: (0)

Quote:
Originally Posted by yeg440i View Post
This is not a BMW issue, it is an Apple issue.

Bluetooth / Media problems have plagued other platforms including Audi, Mercedes & Toyota since 13.1. We don't have any real option other than to kick & scream at Apple.

https://discussions.apple.com/thread/250676400?page=1
I am running 13.2 beta and the problem seems to be fixed on this version
Appreciate 0
      10-03-2019, 11:12 PM   #17
yeg440i
Second Lieutenant
yeg440i's Avatar
Canada
232
Rep
259
Posts

Drives: 2017 440i 6MT with MPPSK
Join Date: Nov 2017
Location: edmonton, alberta

iTrader: (0)

Garage List
2006 BMW 330i  [0.00]
2017 BMW 440i Coupe  [0.00]
2007 BMW 335i  [0.00]
Quote:
Originally Posted by Nonopr01 View Post
Quote:
Originally Posted by yeg440i View Post
This is not a BMW issue, it is an Apple issue.

Bluetooth / Media problems have plagued other platforms including Audi, Mercedes & Toyota since 13.1. We don't have any real option other than to kick & scream at Apple.

https://discussions.apple.com/thread/250676400?page=1
I am running 13.2 beta and the problem seems to be fixed on this version
13.2? You mean 13.1.2? If so, you must be a lucky one off then because tons of people including myself were on 13.1.2 & had nothing but issues.
__________________
2017 440i 6MT Alpine White over Coral Red Leather 2007 335i 6MT Black Sapphire Metallic over Terra Brown Leather
2006 330i 6MT Arctic Metallic over Ivory White Leather (SOLD)
Appreciate 0
      10-04-2019, 06:00 AM   #18
Nonopr01
Lieutenant
99
Rep
521
Posts

Drives: 2017 BMW M3
Join Date: Aug 2015
Location: San Juan, PR

iTrader: (0)

Quote:
Originally Posted by yeg440i View Post
13.2? You mean 13.1.2? If so, you must be a lucky one off then because tons of people including myself were on 13.1.2 & had nothing but issues.
13.2 Beta for me.
Appreciate 0
      10-04-2019, 07:54 AM   #19
Encanto
Major
Encanto's Avatar
451
Rep
1,198
Posts

Drives: 2018 M3
Join Date: Nov 2015
Location: Florida

iTrader: (1)

https://www.bmwusa.com/owners/software-updates.html

Again... try updating the Media version in the iDrive first, unpair/delete, and pair again. Three BMW (and a VW) in my family and have no issues with all versions of the iPhone 11 (11, Pro and Pro Max).

The latest the Media version is in the iDrive, the more stable the iPhone will be regardless of iOS version.
Appreciate 0
      10-04-2019, 06:25 PM   #20
IK6SPEED
Major General
IK6SPEED's Avatar
United_States
3586
Rep
9,110
Posts

Drives: BMW M3 / AH3
Join Date: Jan 2013
Location: Cali

iTrader: (20)

Quote:
Originally Posted by yeg440i View Post
Quote:
Originally Posted by Nonopr01 View Post
Quote:
Originally Posted by yeg440i View Post
This is not a BMW issue, it is an Apple issue.

Bluetooth / Media problems have plagued other platforms including Audi, Mercedes & Toyota since 13.1. We don't have any real option other than to kick & scream at Apple.

https://discussions.apple.com/thread/250676400?page=1
I am running 13.2 beta and the problem seems to be fixed on this version
13.2? You mean 13.1.2? If so, you must be a lucky one off then because tons of people including myself were on 13.1.2 & had nothing but issues.
He means the beta version of 13.2
__________________
Stable: F80 / AH3
Past: F80 ZCP / F22 M235i / E89 35is
Appreciate 1
yeg440i231.50

      10-08-2019, 09:36 AM   #21
Alan l.
Major General
Alan l.'s Avatar
2704
Rep
7,044
Posts

Drives: 2018 Individual M3 6MT
Join Date: Jun 2009
Location: United States

iTrader: (9)

Anyone else noticed that their contacts name no longer shows up on the i drive when theirs a incoming call?

This by far is the most buggy and troublesome update from Apple to date. IOS13 also rendered most dash cam apps useless because it thinks it can't connect to the wifi network even though it is.
__________________
Appreciate 0
      10-08-2019, 09:34 PM   #22
RickFLM4
Brigadier General
RickFLM4's Avatar
United_States
3888
Rep
3,713
Posts

Drives: M4
Join Date: Jul 2015
Location: PB County, FL

iTrader: (0)

Quote:
Originally Posted by Alan l. View Post
Anyone else noticed that their contacts name no longer shows up on the i drive when theirs a incoming call?

This by far is the most buggy and troublesome update from Apple to date. IOS13 also rendered most dash cam apps useless because it thinks it can't connect to the wifi network even though it is.
Yes same thing with messages as well. Iím not going to screw around trying to resolve. Just need to wait until Apple resolves. I also have the issue OP noted of not being able to control playlists and the link in an earlier post makes it clear this is an iOS issue as it is across auto brands.
__________________
Current: 2018 SO/SS F83 ZCP
Gone: 2015 SO/SO F82
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:12 PM.




f80post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST